About none root user use hibernate option in "power manager"

I installed zorin os lite on my laptop yestoday. It works fine now.
But it has a shortcoming, that is, there is no hibernate option in power manager


I want my laptop to go directly into hibernate after closing the lid cover so that the next time I open it I can get back to my previous working state as soon as possible.
I have installed hibernate as follows
sudo apt install hibernate
But there is still no hibernate option in power manager
Later, I thought that there is a hibernate option in power manager when running zorin live cd, so I doubt whether it is a permission problem.
So I execute the following command
sudo xfce4-power-manager-settings
As a result, the hibernate option appears, as follows:
pm-1
Do I only have to log in with the root account to use it? Does anyone know how to solve this problem?
That is, the general user logs in, and the hibernate option appears in the power manager

2 Likes

I suppose Suspend and Hibernate are do the same Work!

5 Likes

There is a big difference between the two. Hibernate writes the contents of the memory to the hard disk, and the computer is completely powered off, while suspend is only placed in the memory, similar to sleep.Hibernate does not consume power

1 Like

According to the new Update, The Hibernate option was removed in every new version of Zorin. So, There is nothing you we can do?

5 Likes

So why is there this option in sudo and live cd?

2 Likes

Sorry, my bad Check out this Post:-

https://www.linuxandubuntu.com/home/how-to-enable-hibernate-in-ubuntu-linux#:~:text=Hibernate%20saves%20all%20of%20your,once%20you%20fulfill%20the%20requirements.

5 Likes

I have read this article, it can only add the hibernate option in the start menu, but it can't act according to the opening and closing of the laptop lid.

3 Likes

got your answer:-
after the procedure in the above article, reboot the device and then open power manager < system then set this setting to :- hibernate

4 Likes

I tried MX linux, it has hibernate option by default for normal users, it can work without any other settings.
Another problem is that, for some reason, after logging in to the zorin desktop, the numlock light stays on and cannot be turned off (pressing numlock does not respond), whether in the vm or on a real laptop.

This may help or hinder: