Almost ready to dump Zorin 16

Each time I shut Zorin 16 down and then start back up I have to reset my sound then my screen saver. I have tried just about all the suggested code and programs I could find. Oh, and my wireless mouse would not work right from the beginning and I had to end up using a wired mouse. Again I tried a lot of the suggestions I could find. Any help would be appreciated.

1 Like

@zabadabadoo , if you are finished derailing threads, this user needs your wizardry.

Can you please expand on what you mean by this?

what are the specs on your mouse?

The screen saver I installed from the software link in Zorin xsreensaver it's called. The mouse is a logitect M525 the speakers are also logitech. I tried some of the suggestions for the mouse, but no luck.

Perhaps @StarTreker can help on troubleshooting Logitech. Is it Bluetooth?

Can you please describe what Xscreensaver is doing that requires it to be reset?

1 Like

Don't even want to tell you how I had to end up using my Zebra TLP 2844 label printer which is not really made for Linux.

Regarding getting Logitech devices to work, its advised to install Solaar, which can be found in the Software Store for easy of installation. I am using the Lotigtech MX Master 3 wireless mouse with my old dual core machine with Zorin OS 16 on it.

The way I have it conencted up, is that I am using the LOGI bluetooth adapter that it came with, connected to one of the USB 2.0 ports. And guess what? With Solaar installed and configured, it works just fine!

Screenshot from 2021-10-15 10-33-09


It does sound like you've had enough frustration to tear each fingernail out one by one.
We've had other users threads on Zebra and they were tedious, to say the least.
Makes me glad I print my shipping labels out on a Lexmark.

Yes, the screen saver will work after I start it up each time and work well. After I turn the computer off for the day and start up the next day it will not start if I leave the computer for awhile. I then have to go in and restart it for it to work again.

Yes, it's an older one, but I installed Windows 10 in a VM to get it tto go works great now. I tried Wine first with no luck.

1 Like

Do you mind if I ask why you replaced the default gnome-screensaver with xscreensaver? Was the default screensaver also not working?

I did install Solaar with no luck. I will give it another try maybe I missed something in Setup

Well no reason really, just wanted a bright screen saver, the computer screen would just get dark after 15 min and I wanted a bit more splash. A new computer build I'm sure you understand.

As a themer, I understand completely.
Gnome-screensaver leaves much to be desired.

I am going to post a series of Terminal commands that should quickly and efficiently help get you set up on Xscreensaver. You can open terminal with ctrl+alt+t

sudo apt install xscreensaver xscreensaver-gl-extra xscreensaver-data-extra && sudo apt remove gnome-screensaver

This will install any additional necessary packages and set your current packages to manually installed.


This will open a popup GUI window to add a new autostart application.
Click the add button on the right hand side.
Name: Screensaver
Command: xscreensaver -nosplash
Comment: anything you want.
Click add on the lower right - and that should solve the Screensaver issue.

You can open xscreensaver from the Zorin App menu and set your configurations if you need to.

1 Like

Thank You I will give this a try and let you know how it turns out.

1 Like

I see that the first command removes the gnome screen saver I'm picturing a scene from Young Frankenstein "It Could Work" . Thanks again you guy's are really fast.

1 Like

Yes, I tacked that on to ensure that the gnome-screensaver application does not interfere with xscreensaver. It really is best to use only one screensaver at a time.
The Screensaver application is what is actually used to handle the Lockscreen. You can see how having more than one installed can cause an issue, there.

@Mr_Carrasco Please open terminal (ctrl+alt+t) then run alsamixer
Make changes to get your sound working. I assume as you have got it working before, you know the trick to that.
Then from terminal save your alsamixer setting using:

sudo alsactl store

That should save your alsamixer settings over a reboot cycle.

If you still have trouble with sound, post a screenshot of your alsamixer display.

1 Like

Well I did this, but it goes back to this default setting.

I use Xscreensaver, but you have to put it into the startup menu otherwise it will not restart automatically and you will have to open it up every time to start it after reboot.

If using Gnome; Go into your app menu, enter Startup and click on the startup applications. Click on add, Name: Xscreensaver, Command: xscreensaver-nosplash click add. Make sure there's a check mark next to it, before closing out the start up apps.

Make sure you added everything (I use synaptic, not the store) for Xscreensaver to get all the options available. Also, remove gnome screensaver from the system. It has a habit of interfering with Xscreensaver.

I have to reset it to this setting.