Amazon Gaming not working

Tried to get Amazon gaming to work, but the Window does not open. Possibly because it isnt supported on linux, but maybe someone has an idea?

Amazon Games is not supported in Linux, but some work it through Wine.
You might try ensuring that wine is fully set up.

sudo apt-get install -y zorin-windows-app-support

done, but still no Amazon Gaming.

Could you please describe what you see and what happens in detail? Is the app listed in the WINE category on the App Menu? How are you starting the app and what happens when you do? For example, do you click to run and nothing at all happens?
If you open System Monitor, then try to open the Aamazon Gaming app, does any process start in SysMon?

It is Listed in the Wine Category.
Double klicking the icon, then it spins for a while, shows up in SysMon and is then gone again.
(also, SysMons UI looks quite beautifull and I find it much more helpfull then Windows Task manager)

Ok, so it sounds like it does initiate and try to run, but crashes out.
On the WineHQ website, I found the following comment (And it is the only comment…)

Works flawlessly as long as you have vcrun2008 and ie8 installed.
Recommended you complete the installation of those requirements using winetricks.

Searching for other .dll that may be needed, I came across the following list:
dotnet20
dotnet40
vb6run
winhttp
iertutil
wininet
ole32
d3dx9_40
dotnet35
vcrun2015
dotnet45
dotnet46

Some posters on Reddit claimed that they had more luck running it on Lutris.

I am sorry I am not much help. I do not use Lutris, Wine or Windows Apps on Linux. I do have Wine installed on the Shop computer to handle some Automotive diagnostic software but that is it.

I still need to understand how to get A. Gaming into Lutris, but Lurris did help me with another problem… So the next question is solved, but not this one.
I will keep you up to date.

It works via Lutris and then the Twitch Launcher.
It is not the most streamlined soultion, but it is working, so im not complaining.

2 Likes