Apps with install with .configure, make , make install not installing in zorin

apps with install with .configure, make , make install not installing in zorin, I have tried to install a lot of apps with that way, and not worked, it's finished by error:
make: *** No rule to make target 'install'. Stop.
the last thing i have tried to install with this way was docklike plugin( i now there r way to install docklike, with sudo apt install dock..) , but i want to install it with the make , make install way, because i have edited the code

That's a little vague. Usually you need to read the developers instruction on how to compile and install it as there are many ways the developers could put it together.

1 Like

i always follow the instruction of instilling , but no way, i will try again , but i found a lot of users have that problem when trying installing that way of apps(error:make: *** No targets specified and no makefile found. Stop.), they suggested installing some packages, but no thing work with me

If there's no make file, perhaps it's using cmake or other compling tools. There's also the possibilities the files just need to be manually moved to the correct place on your system. ANother options is that the app you trying compile is poorly written :stuck_out_tongue:

1 Like

may be, the first app which required that way of installing was orage(calendar in xfce), Aravisian has helped me in it, i think he edited some thing in it, and send me the link of the edited app, and i installed anthor packge also to solve it.

there r a lot of apps require that way of installing i want try it which they r xfce apps new release , but not one worked

it's worked with me, the ./configure show me that there r packages needed to download, but when i go to install that packages , i found it already installed , so I realized the problem is that package is installed but there r other packages with the same name but appended with -dev word(libwnck-3-dev,etc), which i have to installed the package, and it's worked good

1 Like