Are Zorin's repo down or its just me?

Hi guys. I was demoing out ZorinOS 16 Core on a virtual machine, but for some reason I couldn't get an update? It has been that way for two days.

I'm still pretty much a linux newbie in general but the repo issue has been a weird one, considering the ubuntu repo is working fine and the mint repo (on my host OS) works fine too

Edit: Solved. Check #5 for solution and #7 for the end result. Repo source is looks same from screenshot above. Maybe key has changed? No idea :confused:

Hi and welcome to the forum :slight_smile:

Please make sure your update server is set to a Main server not a local one.

1 Like

Apologies if it sound ignorant but how do I do that? When I installed ZorinOS, I've turned off the "update during installation" option, or something similar during the installation to get a feel of how Zorin handles update. It came with those repos, and did unticking the option caused the repo to be incorrect?

I think the default setting uses Local server.
But the consensus here is that Main server is more reliable.

You can change the setting in

Software and Update

Select Main server from the drop-down list.

If it is already set to the Main server, we will try to solve the issue in another way.

1 Like

It's already the main server. I tried switching to a different mirror, and back to main server. Does the server selection applicable to ubuntu's repo only, or does it affect ZorinOS's repo too? As both times it displayed the same message.

Interestingly, despite the warning messages, I still have some items available for updates. Will try applying them and see if this fixes the issue

You could also update and upgrade from the Terminal (one line at a time).
sudo apt update

sudo apt upgrade


ok, i've completed the update that software updater has pointed me to, despite some of the repos being offline.

ran sudo apt update after the updates

Edit: repo looks the same. perhaps keys are updated during the software update? no idea :confused:

thanks FrenchPress, for helping out :DD

Sometime, inexplicable thing could happen in Linux (way less than Windows I might add).
I am a very pragmatic person and I am OK with that as long as it works.

You are welcome :slight_smile:
If you think the problem is solved, please mark the thread as solved by ticking the box :ballot_box_with_check:
This will help the future visitors to the site to find the answer they are looking for.


Same here, I'm fine as long things works. Although if it doesn't I'll usually seek to understand why it behaves this way :slight_smile:

Yep, there have been a few update related issues on the forum lately. Which is why I occasionally update the forum to let you guys know how my update experience has been going.

To date, I have only had 1 issue updating 1 time, and that was solved after either a reboot or waiting a day, I haven't had any serious update issues that required extensive commands to fix yet.

I am glad that this issue is now fixed for you, you are stellar! :star2:


To be sure, please run:

sudo apt install ca-certificates

sudo apt install --reinstall ca-certificates


i'll take note of this when I install ZorinOS on a real hardware. Thanks for the tip :DD

Thanks! I don't know why, but this fixed all the errors that were showing up when I ran "sudo apt-get update".

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.