AX210 Killer Card not showing in Zorin Pro

Hello. I have upgraded to Zorin Pro - and the wifi card and driver have now gone. I only have bluetooth and ethernet available. I dual boot with windows and I have secure boot disabled and also fast boot disabled. I'm at a loss as to why the iwlwifi driver / device is now not showing?

Thanks

CPU: 10-Core 12th Gen Intel Core i7-1280P (-MT MCP-) speed/max: 401/400 MHz
Kernel: 5.15.0-78-generic x86_64 Up: 47m Mem: 2446.6/15684.8 MiB (15.6%)
Storage: 476.94 GiB (5.7% used) Procs: 368 Shell: bash 5.0.17 inxi: 3.0.38

$: sudo lshw -C network

*-network UNCLAIMED
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix cap_list
configuration: latency=0
resources: iomemory:600-5ff memory:603d19c000-603d19ffff
*-network
description: Ethernet interface
physical id: 2
bus info: usb@3:3
logical name: enx3e1eb5292328
serial: 3e:1e:b5:29:23:28
capabilities: ethernet physical
configuration: broadcast=yes driver=ipheth driverversion=5.15.0-78-generic ip=172.20.10.3 link=yes multicast=yes

Using ethernet or hotspot to connect to the net, can you try the following:

sudo add-apt-repository ppa:canonical-hwe-team/backport-iwlwifi

sudo apt update && sudo apt install backport-iwlwifi-dkms

Reboot and test...

*-network UNCLAIMED
description: Network controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 14.3
bus info: pci@0000:00:14.3
version: 01
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress msix cap_list
configuration: latency=0
resources: iomemory:600-5ff memory:603d19c000-603d19ffff
*-network
description: Ethernet interface
physical id: 2
bus info: usb@3:3
logical name: enx3e1eb5292328
serial: 3e:1e:b5:29:23:28
capabilities: ethernet physical
configuration: broadcast=yes driver=ipheth driverversion=5.15.0-78-generic ip=172.20.10.3 link=yes multicast=yes

Hi and thanks for the commands. Sadly it made no difference and the wifi card is not being picked up?

Thanks

Can you run

sudo modprobe -r iwlwifi

sudo modprobe iwlwifi

Reboot and test...

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.