Bad behavior, 1 of 2 external monitors black, many settings not staying set

Brand new user here. I have 16 pro installed on 2 very different systems

system 1:
Ancient Asus k54c (Upgraded ram to 16gb and installed ssd drive) issues? not sure, but not that many?

System 2: 2020 System 76 Gazelle 15 w/Nvidia (Forget which model) all the ram, i7 6:12 5ghz intel i915 isssues: all the issues

i know I can in-theory ignore the possible missing firmware messages but I wonder if fixing that might fix the rest of these.

I have 1 of 2 external monitors blank after update. Downgrade did not fix the issue...... seems OK on USB boot disk
possible missing firmware
no 5g networks on internal but external wifi adapter shows 5g exist. (This computer JUST passed its 1st birthday)

cannot search Software. More than 4 letters and it just gets confused and finds nothing but wont stop searching.
i would like to generate or look over logs, but Im new, please tell me how. There are probably 10 or more issues I am having with the new computer.

I wouldn't hedge bets on it, but you can try it.
Here are the firmware files.
Extract the file, then elevate your file manager to Root:

sudo -i


Once elevated, move the Firmware files (NOT the folder that they are in, the actual files themselves only) to /lib/firmware/i915


your help is much appreciated, and yeah, i am not holding my breath

not sure if this was the fix but the only issue i have now is minor nonsense

thanks, again

Minor can become major if it annoys you for long enough. What remains?

I think something needs to be cleaned, contactwise... I'm havin weird keyboard issues so I have to use an external

1 Like

Sometimes, it comes down to this. As a computer ages, we must also accept the Hardware, too.

1 Like

Cleaning contacts did nothing... but its all working now. the monitor or computer doesnt like the adapter, but it worked on another computer

I want to issue a thank you to Aravisian as well. I am currently running on the Zorin OS 16 PRO LITE distro, and when I did a sudo apt-get upgrade command, it showed me a whole list of I915 missing firmware, I was honestly shocked to see that.

So, I just followed the steps provided here, downloaded the firmware files, extracted them, and only placed the files themselves, into the /lib/firmware/I915 folder. I am guessing I just run the upgrade command again now I suppose.


I ran the command, no errors! Finally, something going right on XFCE lol.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.