Battery Draining Way Too Fast

Hello, so I have this issue with my laptop, my battery life is very poor, and I already know that this is a common issue with linux, but I can barely make it to one and a half hours without having to plug it back in, I have installed tlp, slimbook battery and now i'm using auto-cpufreq.

And even trying all of those they give almost the same result, I have put a timer of 10 minutes and it drained 6% without even doing or touching anything or having anything open, except the settings window.

Isn't it a bit too much that even after downloading all those things and bringing my brightness all the way down to 25% or less, I still can't even make it to 2 hours? I know my laptop isn't the best out there but I would at least expect that amount.

Is it this bad with other laptops?

Some other things you might try:

  • Remove nonessential things from StartUp
  • Calibrate your battery. You may be seeing unusual drain due to poor calibration.

I have pretty much removed everything that is non-essential already but will try recalibrating my battery. That is done by charging to 100% then letting it drain till it almost 0%? Or do I do something else?
Thanks for your reply btw

Correct - the comment above also includes an embedded link to instructions.

1 Like

Does Zorin come with TLP installed and is that recommended anymore? I know that used to be a big thing to install for laptops but I have only used Linux on desktops in quite a while so I am not familiar if that is a good recommendation anymore.

(I know for a fact it is not there on my desktop. But was wondering if it automatically installs for laptops or if it is even needed anymore)

No, TLP must be installed by the user.

Sure, it often still works well. If it has no noticeable effect, then it is at worst, harmless.

1 Like

Alright, so I have calibrated it, however it seems to have done little to no change, seems to still dry as much as before, so I'm guessing it has something to do with my hardware (although not the best, brand new). :smiling_face_with_tear: :sweat:

Does your notebook have Nvidia graphics?

Yes it does

That may be part of it. Nvidia drivers on Windows are automatically governed. Whereas on Linux, it is not automatic.
If you alt+F2, then enter in nvidia-settings
Look for Prime Select under Power Saving.

Will check it out when I can, but I remember I had problems with the nvidia panel last time, as it didn't show any options, only an exit button, reinstalling nvidia drivers fixed it temporarily, until I restarted the laptop.

Ok it seems to work, however the Power Saving mode isn't available.
Screenshot from 2023-05-04 19-17-48

Is Intel (power saving) grayed out?
Does your notebook have an integrated Intel graphics card?

Yes and yes

Well, at least it is set to "On Demand", which should kick in Nividia on an as-needed basis rather than running it all the time.
But it does concern me that your Intel option is unavailable. Maybe another user that knows more can help clarify this...

In the meantime, could you relay the terminal output for

sudo lshw -C video

Here it is.

Do you think that switching to Zorin OS Lite or other distros would make enough of a difference? Or could it just be a hardware problem?

I prefer Zorin OS Lite, anyway. I have a pretty new Machine.

I find the "Lite" name to be a bit misleading. it is good for older machines, but not exclusive to them. Lite has everything that Core does - and more. It is a full featured desktop.
It is called "Lite" because it runs lighter, not because it is stripped down.

Looking at your screenshot above, it is clear that your Intel card is recognized and has the driver for it.

I see, thanks for the clarification, maybe I'll try Lite if I'm not able to find a solution. :slightly_smiling_face::smiling_face_with_tear:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.