Black screen after boot screen post update

After running an update, I noticed that one thing was being kept back. As I recently had this issue, and had solved it using Synaptic, I decided to do the same thing. After using Synaptic to update the package, I am no longer able to use my device.

After "Zorin" flashes across the screen, it is then a black screen permanently. I have tried recovery mode: checking for broken packages, checking the file system, updating grub, no luck.

I'll be locked out of Zorin until I have a solution.

Can you state which package/app was involved.

I'm not sure how I'd go back and see it but I believe it has"lib... i1863" or something like that.


Yes sir

Behold my ignorance on display once more. You always get front row seats :joy:

You should be able to access a terminal from Recovery Mode.
Boot and start tapping the esc or the tab key when you see the motherboard splash screen. If you are booting Legacy (MBR), hold down the Left Shift Key, instead.
You should see and select Advanced Options for Zorin
Arrow key down to drop to Prompt...
Hit enter
Then run:

grep "install" /var/log/dpkg.log

You can also try:

grep "upgrade" /var/log/dpkg.log

You can use your cell phone to take a photo of your screen to make it easier to relay that information here.

Root option?


That is odd... why is the Ubuntu-Release-Upgrader on there at all? You are on Zorin OS, not Ubuntu.
What is the output of:

cat /etc/update-manager/release-upgrades

1 Like

Ok, good. That is set to "never" and it currently needs to be...

What is the output of:

sudo apt install --reinstall ubuntu-release-upgrader-gtk

Huston we found an error

sudo dpkg --configure -a

sudo apt --fix-broken install

Please relay the output...

First output

Ok, can you exit the prompt and return to the Recovery Menu.
Arrow key to Enable Networking
Once enabled, back to the recovery menu, arrow to to Root and drop to prompt and run the commands again...

Second output

After networking enabled

Please see the reply above after your first output. Once that is done and you return to prompt...

sudo apt install --reinstall zorin-os-desktop

Your autoconfigured list in your second output is frightening. Python, Gnome, etc - have all been removed from your system.
You might relay the output of:

grep "remove " /var/log/dpkg.log

So we can see what was recently removed. But currently, I have my fingers crossed that you have backed up your personal files recently...

I am able to access all my files from a live USB of Zorin. I checked immediately. But how could updating one package have removed my entire desktop environment?

Should I back up my files before reinstalling Zorin OS with the command you gave?