Black screen after installation via safe graphics mode

Hello all, i have an issue after installing zorin os 17 via safe graphics mode, in fact the normal mode doesn't work for my pc (it is an old one, but technically would support zorin), showing a black screen. Then, when the installation was done, rebooting, it shows me again a black screen after the zorin logo, with only the cursor visible, not working though. After some research online i tried to add 'nomodeset' in the 'GRUB_CMDLINE_LINUX_DEFAULT' line, and it worked, even though the pc was very slow. But this was just temporary, so now what can i do to at least boot in safe graphics mode permanently, even if I'd prefer to have perfect compatibility with the normal mode? Thankss

You can add/edit

sudo nano /etc/default/grub

You video card may not be supported anymore, but give us the output of:

sudo apt install inxi
inxi -Ga

Welcome to the Forum!

You wrote, that You have an older PC. Could You specify that? Maybe then would be Zorin Lite a better Choice.

yes, after booting in safe graphics mode it shows this:

Graphics:
  Device-1: AMD RV620/M82 [Mobility Radeon HD 3450/3470] vendor: ASUSTeK
    driver: N/A alternate: radeon, amdgpu pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 bus-ID: 01:00.0 chip-ID: 1002:95c4 class-ID: 0300
  Device-2: Syntek Sonix 1.3MPixel USB 2.0 Camera type: USB
    driver: uvcvideo bus-ID: 3-5:2 chip-ID: 174f:5a35 class-ID: 0e02
    serial: SN0001
  Display: x11 server: X.Org v: 1.21.1.4 compositor: gnome-shell v: 43.9
    driver: X: loaded: ati,vesa unloaded: fbdev,modesetting,radeon gpu: N/A
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 1024x768 s-dpi: 78 s-size: 333x212mm (13.1x8.3")
    s-diag: 395mm (15.5")
  Monitor-1: default res: 1024x768 size: N/A
  OpenGL: renderer: llvmpipe (LLVM 15.0.7 128 bits)
    v: 4.5 Mesa 23.2.1-1ubuntu3.1~22.04.2 direct render: Yes

i tried time ago to install the lite version, but in that case it freezes on the users screen, anyway the pc is an Asus x50sl

When I see it from Your Output right, you use X11. Did You tried it in Wayland Mode?

sorry but not knowing very well ubuntu I don't know what is the wayland mode, i searched and i saw that the WaylandEnable=false line is preceded by a #, i don't know if this helps

1 Like

Sorry, I had it should explain what to do. When You are on the Login Screen click on Your Profile so that the Password Field appears. It must appeared! After the Password Field ist appeared You should see in the bottom right Corner a Gear Icon. Click on it. Then You should see 2 Options:

Zorin Desktop
Zorin Desktop on Xorg

What Option is chosen You can see at the Dot that marked the Option. Die first One is the Wayland Mode, the second One the Xorg Mode. Change from the active Mode to the other and then test if it works better.

i'm sad to say that there is not a gear icon, but with the computer i'm using, on the login screen, actually there is it, so i don't know

Please explain, as your post seems to be contradicting itself re presence of gear icon on login screen.

Are you talking about login screen on 2 different computers?

What graphics card does it have?

oh yes sorry, obviously i ain't writing from the computer with problems, i wanted to say that the older pc doesn't have a gear icon maybe because i can boot only with the recovery mode, otherwise i get a black screen before the login screen. I hope i explained better