Black Screen after Selecting "Try or Install Zorin OS"

Hi there
I am trying to roll out Zorin OS in my club on some HP Compaq 8200 Elite SFF PCs on which a Win10 is still installed. The usb boot stick (created with Etcher and Zorin OS 15.3 Core) is not showing up in the boot menu. So I have selected “Run UEFI Application…” and selected USB->EFI->BOOT->GRUBX64.EFI.

The grub screens starts and show the different booting options, e.g.

  • Try or Install Zorin OS
  • Try or Install Zorin OS (safe graphics)
  • Try or Install Zorin OS (nvidia)

I tested all options and all of them result in a black screen (with no mouse showing up).

I tested the Live USB Stick on a old Fujitsu Lifebook as well as on a new HP Spectre and there the “Try Zoring” works perfectly.

I disabled all security options in the BIOS of the HP Compaq and tried again without results.

I found some related posts but no solution of them worked:

Any help is very appreciated.


Hi, Merlin.
What you did seems to have taken care of #3 here USB boot install
Can you check for #4,#5 as well and let us know if that helps?
FYI, that is not an exhaustive list - there may be other ways Win 10 prevents other OSs from installing. You’d have to research those, should they exist.

Hi Carmar
Thank you very much for your answer.
I booted back into the old windows OS and can confirm that
4) Fast Startup
5) Bitlocker encryption
is disabled.

Also if I remove the harddrive (where the win 10 is installed on), the black screen still shows up - so I think it has nothing to do with windows at all.

Do you have any other ideas?


Can’t think of anything else. You wrote, in your original post that you did try the second link where Aravisian had suggested adding nomodeset to the grub. That should have at least allowed basic graphics. If that is not working then I suspect it is still a USB or BIOS issue, not a graphics one.
You wrote that you used a “Run UEFI” option - is there at all a “Legacy” option? I’m trying to see if you can avoid UEFI completely.

I did a complete reset of the BIOS which solved the problem. Afterwards, I was able to select the USB Drive as Legacy Boot and it worked even without safe graphics.

Thank you very much for your help.


1 Like