Black screen after update/upgrade

Kernal 27, not 37 ? Just checking first.

1 Like

Yes, due to greater confidence in it than the -37.

Okay, I will check the boot.

1 Like

It would not boot into 27, unless I selected "Recovery Mode" Otherwise, it just sat on the Zorin splash screen, just like when I picked -37, without recovery mode.

Ok on either the -27 or the -37, can you tap the e key at the Grub menu, first. In the editor, change "quiet splash" to "quiet splash nomodeset", once done, back out to the grub menu, select recovery, then try Regular Boot on the -27 or the -37 kernel and see if it will boot.
If that doesn't work, you can boot however works, then open terminal and

sudo nano /etc/default/grub

Change it to "quiet splash nomodeset", then ctrl+x to exit, y key to say yes to save, then enter key to save.

sudo update-grub

Then reboot and try to boot Regular Boot of -27 or -37.

What is the "Grub menu" please?

The Grub Menu is the menu you have been using to access Recovery. It is the menu that can appear at Boot, allowing you to select with OS to boot up, or which kernel to boot from.

Okay, thanks. There is a lot that I don't know, and I appreciate your help. Trying it out.

1 Like

That makes two of us.

The second option (sudo nano /etc/default/grub) worked--I still had to pick the kernal -37, but I did not have to select recovery mode.

1 Like

Ok, let's remove the Bad kernel:

sudo apt remove --purge linux-headers-5.11.0-38-generic linux-modules-5.11.0-38-generic linux-modules-extra-5.11.0-38-generic linux-image-5.11.0-38-generic linux-headers-5.11.0-27-generic linux-modules-5.11.0-27-generic linux-modules-extra-5.11.0-27-generic linux-image-5.11.0-27-generic

Once that is done: Synaptic:

sudo apt install synaptic

Launch Synaptic, enter PW for Root Permissions, then search using the top toolbar Search button:

Select all listed packages for that kernel That are installed currently and then click the Package item on the menubar at the top.
Move down the drop down menu to Lock Version and select it.
This will prevent the kernel from updating to the -38 problem kernel.

Where is "PW" entered?

When you launch Synaptic, a PassWord field will open.

That was asking me to authenticate. "PW" was not accepted.

Your password. PW.

Two listings--one "generic", one "lowlat" Select both?

Any that are installed.
Should be generic. I would be surprised if you were using low latency.

The term "Apply" is not lit up, what do I do to apply this?

You do not need to hit "apply" in this case, selecting "Lock Version" locks it in. To unlock, click the "lock Version" checkbox again to deselect it.

Okay, thanks. I suppose that this is all, right? I will try the boot one last time then.

1 Like