Black screen fresh Zorin OS 16 install -AMD

Hello all. I installed Zorin 16 Pro on external hard disk before I used "try Zorin" everything working. After successfull instalation i get a logo and a name Zorin and then only black screen. My graphic card is radeon r9 390 the drivers are on webside amd. I don't see any menu grub to change things and how to in a grub.
Please for help on main webside Zorin is wroted all drivers after 2013 are implemented in Zorin 16 Pro. I need help how to install drivers somehow but i don't know which buttons can help with rescue or go to the terminal in 16 Pro.

Ok. I off all hard disk and installed from usb on external hard disk ssd. I saw everything with esc was green. I saw loadind logo zorin and name and then black screen. I reading on main webside if your graphic card is over 2013 then we have implemented drivers. So i am now tried to grub with tab or left shift but this is not working when i try edit grub. What solution to get inside grub and install drivers graphic amd radeon r9 390x?

1 Like

I know that after installation i will get a black screen like before in 15.3 ultimate but in 15.3 was a menu to edit grub in 16 pro doesn't exist menu.
What is solution for this problem. I can see a grub menu from installation image ISO but I don't see after installation this on external hard disk. Also I know that i will get a black screen after installation.

Can you help me with this problem? With try Zorin operative system working but when full installation i used not working how described under.

Can you hold the Left Shift Key from the moment of Boot Up in order to enter the Recovery Menu?
Once into the Recovery Menu, arrow key down to "Drop To Prompt"
Hit enter...

sudo nano /etc/default/grub

You should be able to edit grub as before from this screen.

I tried this when i boot and clicked left shift button and don't see a recovery menu.
I can try with old keyboard. For me all mouse and keyboard from 2010 and 2013 working for this day. I will try again push left shift button again. when i choose a boot hard disk with F11.

1 Like

I wonder if your grub timeout is set to Zero.
In which case... Boot the computer and start tapping the Left Shift key like your life depended on it.

It can take a few tries... :expressionless:

But often, this helps users get into the recovery menu. If you succeed and can edit grub, I highly recommend putt the grub timeout parameter to 2 or 3 to prevent this particular Recovery Menu issue in the future.

ok but i need click this left button shift repeatly or after choose boot click once and hold on a button. I don't know what is a fabric time to go in a grub.

You will know if you see the Zorin Plymouth Splash Screen to stop tapping left Shift Key. If the Zorin Logo appears, then it missed opening the Recovery Menu.

If that just does not work, you may be able to edit grub by booting into your Zorin OS Installer Media.

Ok. Everything working. I clicked escape and shift and i get some Zorin grub menu what was 0 second. Then i go forward to root and change things from this forum and now everything working a great.

I will put more pictures when try configure nokia 7 plus with connect zorin.

1 Like

i changed grub with recovery mode go to root using a command sudo nano/etc/grub put information from forum what put and also sudo apt update and upgrade.

To update grub is

sudo update-grub

To update your sources prior to an installation:

sudo apt update

To upgrade packages to a newer version:

sudo apt upgrade

I am not sure what you are asking about the grub configuration file...

I used this solution what working. Zorin OS 16 compatibility graphic cards - #2 by Storm
Changed only parameters in grub what was wroted there and all working.
Now, edit your grub with new parameters:

sudo nano /etc/default/grub

Find this line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" and change it to:
GRUB_CMDLINE_LINUX_DEFAULT="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 amdgpu.dc=1 amdgpu.dpm=1 amdgpu.modeset=1"
Once that is changed, paste this line to the end of the file:
This all parameters i changed and after restart working. Really fast this operative system I appreciate.

1 Like

Anyone can explain this?
I used a terminal with a command inxi -G and i get this

Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Hawaii PRO [Radeon R9 290/390] driver: N/A
Display: x11 server: X.Org 1.20.11 driver: ati,vesa unloaded: fbdev,modesetting,radeon resolution: 1920x1080~N/A
OpenGL: renderer: llvmpipe (LLVM 12.0.0 256 bits) v: 4.5 Mesa 21.0.3
I understand my drivers not installed?

Find some solution from this webside
Then I get from terminal when put a command inxi -G
Device-1: AMD Hawaii PRO [Radeon R9 290/390] driver: amdgpu v: kernel
Display: x11 server: X.Org 1.20.11 driver: ati,vesa
unloaded: fbdev,modesetting,radeon resolution: 1920x1080~60Hz
OpenGL: renderer: AMD Radeon R9 390 Series (HAWAII DRM 3.40.0
5.11.0-27-generic LLVM 12.0.0)
v: 4.6 Mesa 21.0.3
Installed also this
wget -qO - | sudo apt-key add -
sudo wget -qO /etc/apt/sources.list.d/lunarg-vulkan-1.2.182-focal.list
sudo apt update
sudo apt install vulkan-sdk
from this webside LunarXchange

1 Like