Black screen of doom on Live Boot: Asus with Intel Iris XE GPU

Hi all

Would appreciate some help with installing Zorin 16 Pro on a new Asus Zenbook. I hope i've provided all the relevant details below. Many thanks in advance.

The problem:

  1. I'm trying to install Zorin Pro 16.2 Pro 64 Bit (alongside pre installed Win 11). When booting from the install USB in order to install Zorin, I get to the 'Try or Install Zorin' menu fine, but after selecting any of the choices, I get a black screen, non responsive to any keyboard inputs.

  2. I have not been able to get to the Zorin install screen yet, so Zorin is not installed at this stage.


Asus Zenbook UX3404 14.5 inch, 2.8K 2880x1800
CPU: i7-13700H
OS: Windows 11 pre installed
GPU: Intel Iris Xe

Secure boot disabled
Fast boot disabled
Encryption/Bit Locker in Win 11 set to OFF

What I've tried so far:

  • Read the forum posts on this issue and I understand it could be due to the Intel Iris Xe graphics support in the kernel OR 2) Windows blocking the running of another OS.

  • Re-flashed the live boot USB and tested on another Asus dual boot machine (older & with Nvidia graphics) - The USB works fine there.

  • Tried all Live boot menu options (Try or Install, Safe Graphics, Nvidia Drivers etc); they all produce the same black screen result

  • Tried entering the Grub recovery menu by holding L-Shift, or pressing Tab or Esc during boot. I can't get to the recovery menu with the little menu box and all the options (mem test etc), I can only get to the Grub text editor as described below. I also tried Ctr-Alt (F1-F8) during boot as suggested here ([SOLVED] Black screen after install - #2 by Aravisian), but to no avail.

  • Entering the Grub text editor by pressing 'e' at the live boot menu. This brings up the text editor but the text is incredibly small and there is no print on the screen as suggest in the 'ro quiet splash fix' ([SOLVED] Black screen after install - #2 by Aravisian)

  • I ran the 'video test' command and it brought up a blue test screen with some colours and various size text on it. Have not tried any other commands here as i don't know what i'm doing.

  • Tried to replace the 'ro quiet splash' with 'nomodeset quiet splash' but as mentioned above the Grub text editor does not display any text, just the command prompt, so i don't know what to replace.

Any help would be greatly appreciated, as you can tell I don't have any background or a lot of experience with Linux (esp. pre-install/boot issues) but can follow instructions well enough : )

That GPU expects a newer kernel.

The kernel doesn't load a graphics driver for the Iris XE GPU...

... you'll have to use a newer kernel. I'm not sure how to update the kernel used for the LiveBoot version of ZorinOS...

Thanks Mr Magoo

I've read the post linked by you and it appears that therein suggested fixes don't work:

** changed /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT to "", as the way in Ubuntu 20.04 Intel HD 615: No Brightness control or no Boot / Stuck on Boot Screen*
** configure xorg to prefer the Intel or disable modeswitching out of IGD, as the way in Ubuntu 18.04 not working with Intel Integrated Graphics*
** remove xserver-xorg-video-fbdev, as the way in [SOLVED] Screen resolution low, no graphics card driver loaded? - Linux Mint Forums, which only made the boot procedure stuck in splash screen.*

Does anyone else know if it's possible to update the kernel for a Live boot USB? Do I have any other options?


Here's someone else who got Zorin OS working with an Intel Iris XE GPU:

You can try the suggestions in that thread. There should be a setting that'll put the GPU into a 'limp-home' mode that uses basic graphics, and that should get you installed.

Thanks for that. I'll have a look, but i suspect this will be a bit too technical for me to do.

Is this graphics driver issue something that is likely to be solved in new releases of Zorin?

It really should be working in the current. Zorin OS 16 is on the 5.15 kernel. And I believe it includes the linux-oem-20.04, but I am not certain...

The "Try Zorin" mode also delivers black screen? Or Try Zorin (Safe Graphics)?

Hi Aravision

Yes that was my understanding as well.
Yes all the options produce the black screen.

Thanks for the help on this guys, much appreciated, but I've ended up installing Ubuntu on this machine (the wife's comp) as she needs it in a hurry.

If it's of any value to the community here I'm happy to do a bit more testing if that might be of use.


Mind if I ask which version Ubuntu and which Kernel (uname -a) it is running?
I wonder if that may help us find the initial cause.

Not at all; this was the output, if that helps.

Linux anya-Zenbook-UX3404VA-UX3404VA 5.19.0-40-generic #41~22.04.1-Ubuntu SMP PREEMPT_DYNAMIC Fri Mar 31 16:00:14 UTC 2 x86_64 x86_64 x86_64 GNU/Linux

Zorin OS is using 5.15, currently. The higher kernel may have been what you needed for your hardware.
In future, you could try using the TuxInvader kernel:

1 Like

Ok that makes sense. Thank you Aravisian. I think the wife is pretty happy with Ubuntu but i'll see how things unfold.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.