Black screen with blinking cursor when installing

Hey, i have this problem where whenever i try to boot the installer on an old packard bell pc after selecting try or install zorin os it hangs up for a little while and then a blinking cursor appears and it never even gets to the disk check part. I let it sit for around 30 minutes and the cursor is still there just blinking. I have tried safe graphics.

Do you know offhand what Graphics card the machine is using?

It has the Radeon HD 7310

AMD Wrestler...
That should work out of the box with the Linux Kernel.

Have you tried reburning the .iso on a different USB stick?
Try using Rufus, Multiboot or Unetbootin instead of Balena Etcher.

From what I can find online about those hardware specs, it seems to rule out the hardware. This leaves me thinking corrupted Download of the .iso or corrupted burn of the .iso.

The same installer worked with another laptop. I'll try another usb.

I forgot about this thread completely. I've tried 3 different usb sticks with redownloaded isos but it still just flashes a cursor when i select try or install zorin os. I've also tried with safe graphics.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.