Bluetooth blacks out and won't restart

I'm on an HP 4530S with i3 gen3 processor, and Atheros Wifi/BT card sps:593127-001 that is acceptable to the BIOS white list.

I works fine for a while, but eventually passes out leaving me without my BT mouse.

That is all I have on it.

I try to restart BT but it never restarts.
It's the same card doing WiFi, but WiFi never blacks out.
Only BT fails.

One note is that in power management I have to leave Wifi and Bluetooth as "Can be turned off to save power" because if I uncheck them even tough I don't even use the battery, it SHUTS THEM RIGHT THEN.

That should probably be a bug report because obviously NOT wanting to shut them off to save power SHOULDN'T mean shut them off RIGHT NOW!!!!

Any help would be appreciated.

Do you have TLP installed?

1 Like

I did not. Just installed it now.
Looks good. Thanks.
I'll let you know how it goes. Hopefully my BT will stop passing out.

1 Like

This may help but it may also not really help.
If you see no change, we can try reviewing the Wifi and Bluetooth (these fall under radio) drivers.

1 Like

Knock to wood, it seem to have stopped the problem.
Been 24 hours without a blackit.

Any reason this isn't part of Zorin by default?

Because TLP is for Notebook computers that rely on battery usage. Many people use Desktops as well and ZorinGroup cannot assume that all users are on notebook.
There is also .iso size to consider: what will users consider to be Bloatware?
I recall a study performed on Stress in which the outcome suggested that too much stress is harmful to health. But too little is also harmful.
The best results of happiness came from there being a little pressure, a little stress to provide alleviation from boredom, challenge and a feeling of Achievement.
While it may seem inconvenient; You asked and got an answer reasonably quickly. And in so doing, that little bit of stress increased your learning and and allowed you to explore something new.

Sometimes in life, it helps to look at something as, "How can I benefit most? From solving a little problem? Or from having it solved for me, even to the point of never knowing that the problem was even there?"
We cannot spend all the time trouble-shooting (too much stress) but also too little time on it, either.
I mean... Windows is boring.

1 Like

I've had enough stress for a small nation, LOL. So I'm DEFINITELY in the TOO MUCH category.

The good news is I've actually used Zorin 16 enough that I took the plunge and went PRO.

If a big part, do to you and the others being so helpful.

If I can pick your brain for one more thing, do you have any idea of a program that can disable the trackpad on a laptop if a USB mouse is plugged in? Or Bluetooth if possible?

I use trackballs on all my systems, and I'm constantly hitting the trackpad accidently when typing. I had this feature in Mac and Windows, but since I've moved to Linux, this annoyance is back.

Thanks for all your help. Great Job.

Believe me... I absolutely understand this statement...
I'm hanging at the rickety edge on this end.

Yes, Touchpad Indicator can do that.
If using Zorin OS Lite:

sudo add-apt-repository ppa:atareao/atareao

sudo apt update && sudo apt install touchpad-indicator

The icon will appear on the panel and can be used from there.
This may work on Gnome (Zorin Core), I have not tested it. But on Gnome, you can use the Touchpad Indicator Gnome-Shell-extension:
https://extensions.gnome.org/extension/131/touchpad-indicator/

Warning: it is a Gnome Extension and is noted for being Buggy.

1 Like