Bluetooth no longer works since switching to Zorin

Before I switched to Zorin, I had been using Linux Mint (21) where my Bluetooth still worked perfectly, but now it says in the Bluetooth settings that no Bluetooth adapter was found. I have already tried to search for drivers at Intel, but there are only drivers for Windows. My W-LAN still works, although it is the same chip.

I Faced the same issue and found out that the Bluetooth signals interfere with other signals near you ex:- WiFi, transmitters etc. Resulting in shut down of either one of them. Windows have a cure for this but I suppose Zorin doesn't :man_shrugging:. You can use Ethernet cables or run on 5ghz WiFi network in order to prevent this interference and use Bluetooth without problem :wink:

What Bluetooth device are you using?
Is it showing when listed in terminal?

hcitool dev

Current status?

sudo systemctl status bluetooth

sudo systemctl enable bluetooth

sudo systemctl start bluetooth

Have you tried using modprobe to initialize:

sudo -i

modprobe btintel

modprobe bnep

modprobe bluetooth

modprobe brcmfmac

modprobe brcmutil

modprobe realtek

modprobe evdev

1 Like