Boot loop with reset system error after installing zorin on HP 820 g2

Hi, I have issue with booting my laptop
After i install zorin 16.2 core. There is pre installed windows 10 and it didn't give install along side windows option itried some thing else and create partitions manually, when the installation is about complete it give me some errors regarding boot and suggested to run boot repair, i used boot repair it says boot succefully completed but when i restart the computer it shows reset system and restarts again and again.
Any help?

Aravision is one of the experienced people here about Zorin OS, let me contact him along with my other allies.

@Aravisian, @SignorCastello, @zabadabadoo

u might have installed zorin os incorrectly. boot from zorin os live and open disks or g-parted and show us the screenshot of your partions

1 Like

Here is the screnshot of partitions

When i ran boot repair it gives me set your bios in legacy mode then type sudo update grup to add windows entry to your grab menu, but bios is already in legacy i think, its in "legacy support enabled secure boot disabled" option.

I also noticed that boot menu gives me uefi option of live usb and legacy option but i used uefi first but now i select legacy option and it detects that windows and zorin both in the hdd, ideleted zorin partitions created new ones partions it installed without errors but again same error reset system.

Also here is screnshot of boot repair

delete the existing zorin partitions and just boot into zorin live usb using legacy mode (as ur hard drive is working in legacy mode) and select install zorin alongside windows and it will do its thing automatically.

u are installing zorin incorrectly, thats why u are facing issues.

I will try

I deleted existing zorin partitions and installed it along side windows but the issue still not solved, i wonder when i ran boot repair first time it suggests to copy paste some commands on terminal but one command failed which is to install grup-pc can that cause some problems to the boot system.

Ubuntu Pastebin
is my last boot repair summary.
i don't that much knowledge and experience in Linux please any help to fix this problem?

I read through the pastebin printout and saw nothing unusual.

Are you experiencing a Login Loop, rather than a boot issue?

I'm experiencing a boot issue which it says reset system and restarts again and again reset system.

Here are also several times i ran repair.

Does it match this?

It matches, although my first installation wasn't succesfull it shows me that there is fatal error it suggests me to ran boot repair which gives me commands although one command ithink wasn't succeful but i read this post some others talking this issue i also tried to boot from efi file in /efi/ubuntu/grubx64.efi it takes to grub when i write boot it shows you have to load kernel first which is idon't have clue.

Is Windows booting EFI or Legacy? I know you said Legacy was enabled in BIOS... but that does not mean it should be or needs to be...

The Screenshot you shared above for your Gparted screen is very tiny and impossible to read.

Windows is booting in legacy

How many drives? Did you install on a separate drive?

9 some are free space

The image is very small. I believe the only way to view it at proper size is for the viewer to register and make an account with that website.

sda5 looks like the EFI boot partition - formatted to FAT32 with 488megs in size.

If Windows is booting in Legacy, then that EFI partition is likely created for Zorin OS.

If you burned the Zorin .iso with Rufus, I believe that Rufus only burns for EFI bootable images.

You might try booting the LiveUSB installer image on USB and in terminal running:

sudo grub-install /dev/sda6

In order to install as BIOS mode to your existing Zorin Install.