Buggy Dash-to-Dock and Installing Wine

I bought Zorin Ultimate because I wanted to have all the apps and the customization, but it looks like I have a problem with a lot of them. First of all, I can’t use the 4th customization model because of a bug: Dash-to-Dock is really buggy, with time it’s here, later it’s not, the Title bar buttons only appear after switching places twice and I don’t see it for any reason. Also missing some software: Wine, it bothers me because I don’t know how to install it so I’m using a virtual machine and it’s not practical at all.
If anyone can help me, even if I have to reinstall the OS from 0, I will be very happy
Thank you !

Hi, Kap.

Dash to dock: please use Synaptic to search for “dashtodock” (without quotes). Right click the single result that appears and Mark for Reinstallation and then click Apply. See if that fixes your problem.

Wine: please follow the instructions here

and let us know if that helps you out.

Hi camar and thank you for your reactivity!
For Wine, I had the error “Package zorin-windows-app-support isn’t available” so I download it with Synaptic and now it works better (I think it was the problem).
About dashtodock, I tried to use Synaptic doing a right-click on “dashtodock”, but I can only click on “select for install” (I’m not sure about the translation, I’m french) and if I try this with “apply” it says it can’t and ask about repairing broken packages.
Thank you for helping!

I forgot to say, I can enable the dash-to-dock with the 5th template in Zorin Appearance and customize it with the Dash settings that appear in the dashboard tab to look like 4th (don’t really understand why but it works).

Your translation makes perfect sense. If you only get Install option in Synaptic, that is fine too - just select that. When you get the broken package message, select Edit -> Fix Broken Package. Does that allow you to repair the broken package?

On the Zorin Appearance usage itself, I can’t opine. I bought Ultimate last year but never got around to installing it (sheer laziness) so I only have the Appearance offerings in Core (3 layouts).

There are 2 states for this package (in my installation) : “not installed” by default, and “broken” if I select it to install.
I tried “repair” but apparently packages are locked in a “keep as is” state so it can’t be modified. I think it could be changed if this part of the OS don’t start or if we can stop it.

First, close Synaptic.
Then, check that your software updater settings are generally (a few repositories may be different) the same as: Software Updater settings and then run the Software Updater.
Once this is done, type in terminal (ctrl+alt+t) sudo apt install gnome-shell-extension-dashtodock

I have this output :
(I put the system in English to make it easier for you :wink:)

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell-extension-dashtodock : Depends: gnome-shell (>= 3.16) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ok, sudo apt install gnome-shell

I got this :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-shell is already the newest version (3.30.2-2ubuntu2+zorin4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then retried first command, but nothing new

Try, sudo apt install aptitude then sudo aptitude install gnome-shell-extension-dashtodock

So it asked if I wanted to keep gnome-shell-extension-dashtodock in actual version, I said no, it asked if I wanted to use a solution, I said yes and after his installation/upgrade I saw changes in Synaptic. Now the options for dashtodock are :

Mark for reinstallation

Mark for removal

Mark for complete removal

Good. See if it works properly. Let us know how that goes.
PS - I recommend closing whichever installation method you are not using. At least in my case, the terminal some times complains when I leave Synaptic open since both may have root access at the same time and be trying to make changes at the same time.

I retried to set the 4th template for customization but it did the same thing
I restarted my computer but I shouldn’t, now it’s in a boot-loop with Started Hold until boot process finishes up
I think I have to reinstall it… at least we tried

Can you hold Shift key or tap ESC key to enter the Recovery menu and then try to boot?

Yes, I can go to a recovery menu with









I recommend removing the dashtodock first, since likely that is what caused this. First, mount -o remount,rw / then sudo aptitude purge gnome-shell-extension-dashtodock then I believe it is either ctrl+x or ESC to exit the recovery menu. If those doesn’t work, just use reboot or sudo reboot.

I did nothing but I can still go to this :

Sorry, I meant to say “select root” then do all those commands. Let me know if that works.

That’s what I did but still nothing
I have this at boot, my mouse appear and disappear like in a loop