Buggy Dash-to-Dock and Installing Wine

There are 2 states for this package (in my installation) : “not installed” by default, and “broken” if I select it to install.
I tried “repair” but apparently packages are locked in a “keep as is” state so it can’t be modified. I think it could be changed if this part of the OS don’t start or if we can stop it.

First, close Synaptic.
Then, check that your software updater settings are generally (a few repositories may be different) the same as: Software Updater settings and then run the Software Updater.
Once this is done, type in terminal (ctrl+alt+t) sudo apt install gnome-shell-extension-dashtodock

I have this output :
(I put the system in English to make it easier for you :wink:)

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gnome-shell-extension-dashtodock : Depends: gnome-shell (>= 3.16) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Ok, sudo apt install gnome-shell

I got this :

Reading package lists... Done
Building dependency tree       
Reading state information... Done
gnome-shell is already the newest version (3.30.2-2ubuntu2+zorin4).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Then retried first command, but nothing new

Try, sudo apt install aptitude then sudo aptitude install gnome-shell-extension-dashtodock

So it asked if I wanted to keep gnome-shell-extension-dashtodock in actual version, I said no, it asked if I wanted to use a solution, I said yes and after his installation/upgrade I saw changes in Synaptic. Now the options for dashtodock are :

Mark for reinstallation

Mark for removal

Mark for complete removal

Good. See if it works properly. Let us know how that goes.
PS - I recommend closing whichever installation method you are not using. At least in my case, the terminal some times complains when I leave Synaptic open since both may have root access at the same time and be trying to make changes at the same time.

I retried to set the 4th template for customization but it did the same thing
I restarted my computer but I shouldn’t, now it’s in a boot-loop with Started Hold until boot process finishes up
I think I have to reinstall it… at least we tried

Can you hold Shift key or tap ESC key to enter the Recovery menu and then try to boot?

Yes, I can go to a recovery menu with









I recommend removing the dashtodock first, since likely that is what caused this. First, mount -o remount,rw / then sudo aptitude purge gnome-shell-extension-dashtodock then I believe it is either ctrl+x or ESC to exit the recovery menu. If those doesn’t work, just use reboot or sudo reboot.

I did nothing but I can still go to this :

Sorry, I meant to say “select root” then do all those commands. Let me know if that works.

That’s what I did but still nothing
I have this at boot, my mouse appear and disappear like in a loop

Can you try the commands (excluding lightdm) in the solution here?

sudo apt-get remove plymouth
sudo apt-get remove xserver-xorg-video-intel

But then branch off to the following, if you see the dark screen after logging in:
Ctrl+Alt+Fn3 (for you it could be anywhere from Fn2-Fn6, for me it is Function key 3). In the terminal that now appears, type sudo apt install ubuntu-desktop. Then reboot. Then sudo apt install xserver-xorg-video-intel. Then reboot.

I can’t remove because there is not installed and I can’t install because I have held broken packages

Do you have any personal files you need to backup? I’m thinking a OS reinstall may be quicker.

If you choose to reinstall, as long as you don’t select format for your Home partition during installation (“Something Else” installation option will take you to the partitions), your files on Home will be preserved. After reinstall it then appears as a separate volume to mount and access.

Otherwise, we can try to keep troubleshooting. This time, we would select the dpkg option in the recovery menu.

I’ll leave the choice to you.

I think I’ll simply reinstall the OS, I have 2 storages so I don’t need to backup my files and it’s a little bit late here (1AM). I think I just had a rare bug, we tried and it didn’t succed, it happens sometimes.
But really thank you for your help, maybe one day it’ll be fixed in an update! :hugs:

Sounds good - I do the same, I have 2 storages that are separate from the OS. Sorry we couldn’t resolve it and sorry for keeping you late.
If you’re interested, when you reinstall, these are the partitions I recommend: Partitioning during installation

1 Like