Cannot boot from usb from W7 + Zorin dual-boot

Hi everyone,

I have a dual-boot setup with Windows 7 + ZorinOS Core 15.3. I wanted to try other distributions so I flashed PopOS in a USB drive using Balena Etcher, but it seems the BIOS is not recognizing the drive so I cannot boot from it, even though I can navigate the files once I'm within Zorin.

These are a few things I've tried:

  1. Use other USB ports in the same machine.
  2. Flash another USB drive.
  3. Load the BIOS setup (F2) during boot sequence and manually verify the correct boot order. Also directly from the boot loader options menu (F12).
  4. Flash the drive with "Disks" instead of "Balena Etcher".
  5. Try booting from a different computer to confirm it's not an issue with the USB drive. It worked fine there.
  6. Installed boot-repair and run the default recommended repair.

This last one did not really do anything as far as I can tell, but here's the report generated: Ubuntu Pastebin

I'm not really sure what the problem is, is the bootloader or how the USB is formatted? In case it helps to solve this, I've been meaning to get rid of Windows altogether since I use it less and less everyday. So if there is an easy fix by getting rid of it entirely, I'm ok with it.

Any help is much appreciated, thank you!

Accoridng to Ubuntu Pastebin you are using both Win7 and Zorin in Legacy mode, MBR (master boot record). It appears a reading was taking for 'unknown' EFI.
I am guessing here; but it may be that Etcher burned the Pop_OS iso into a bootable For EFI format. This would not necessarily be Etchers fault, as Pop_OS would likely specify it - Pop_OS is geared toward Newer Systems.

Using your Win7, you could use Rufus to create the Bootable USB and set it for legacy, not EFI. (I do not use Windows or Rufus, so I cannot offer much help in how to ensure Legacy that at the moment. I ran a quick net search and saw several video tutorials on it)
You may need to ensure that CSM is disabled in your BIOS settings as well.

3 Likes

Although it is recommended by the official zorin page and included in the install instructions, never use etcher. It destroys more usb drives than it creates installable images. Rufus or unetbootin. In rufus, below the device to flash on the right you will see efi in a dropdown list box... click that and choose legacy. On the left it will change from gpt to mbr. Leave everything else the defaults except the file system, choose fat32. Don't use ntfs, it's not the best for installations and can cause issues. Let us know if you run into more issues or have success in your installation.

2 Likes

Thank you both for your help!

So I've tried to do as suggested and flash the USB using Rufus but unfortunately that did not work, the USB drive is still not recognized by the machine while booting.

Interestingly, the moment I select the PopOS ISO a prompt appears and all the options are grayed out so I can't really change anything, but still it looks like those are the correct settings as per your advice. Here's a screenshot of the prompt, and Rufus window just before I click start:

Back to Zorin, this is what I see when I run fdisk in the terminal:

$ sudo fdisk -l /dev/sdb

Disk /dev/sdb: 3,8 GiB, 4026531840 bytes, 7864320 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x41a72bc3

Device     Boot Start     End Sectors  Size Id Type
/dev/sdb1  *        0 4807487 4807488  2,3G  0 Empty
/dev/sdb2         484    8675    8192    4M ef EFI (FAT-12/16/32)

Which is interesting because it looks exactly the same as when I use Balena Etcher. I'm not an expert by any means but I've been playing around with changing the partition types to try out different combinations of "EFI (FAT-12/16/32)" and "W95 FAT32". At one point the USB was recognized during boot but it only lead to a blank screen so very limited success there.

I've also tried UNetbootin but I always get a weird error saying that the partition has run out of space (did not take any screenshots of that).

Looking around I've found a video that uses Super Grub2 Disk which I will try next and see if that makes any difference. EDIT: Looks like this is not really what I need since the problem is not really a broken bootloader but rather BIOS not reading my USB

Thanks again for the help :+1:

The popup stating that the copy of Pop_OS 'is an ISO Hybrid, but the creators did not make it compatible with ISO/File copy mode' makes me wonder if the Pop_OS help Forum may be more helpful for you. They would be more familiar with that issue.

I could be wrong, but I thought you could just dd ISOHybrid to USB to make a bootable USB.

1 Like

I'm not sure, either.
This lacking of knowing something urks me.

https://www.turnkeylinux.org/blog/iso2usb

These isohybrid images contain in addition to the normal CD-based ISO9660 filesystem, a valid-looking DOS-style partition table. So if you simply "raw" copy an isohybrid processed image to a USB flash drive, the BIOS will boot the image directly.

I was thinking the same and I will try to ask for some advise over at the PopOS forums, although at this point I'm almost certain it has to be related to this machine because other ISO that I have are not recognized either, including the Zorin Core 16 beta.

@FrenchPress How could I use dd, something like dd if="path/to/iso" of="/dev/sdb" ?

The path will depend on your system.
But the syntax looks right to me.

Ok, thanks, I'm not really experienced with dd but I have extra USB drives laying around anyway in case it breaks. Let me try that and see if it works.

But if you will just dd it, you can do so in Rufus - no command line needed.

So, long story short, I did not try flashing other ISO from Rufus setting the partition scheme to MBR as it was suggested above. Just tried this with a few other distros (Zorin Lite, Core and Fedora) and it works just fine... I only tried it with PopOS which is the only one giving trouble, if only I had tried this sooner I would've save a lot of time! :smiley:

I'm guessing my hardware is just old and not supported by PopOS. In any case, I'm going to try Fedora for now and see how it goes.

Thank you all so much for your help, at least I did learn a few things along the way. Cheers!

3 Likes

After hitting the start button it will ask which way you want to write it...make sure to select the dd mode. It offers the iso/file write mode in case the dd mode didn't work. I've installed and used Pop OS, using the dd write method, and never had an issue.