Cannot connect to encrypted WiFi networks

I have Zorin OS 16 installed on my notebook and I am unable to connect to encrypted wireless networks. It keeps asking me for the password and refuses to connect. I however have no issue whatsoever connecting to unencrypted networks. Is there a way to fix this? Thanks in advance for the help.

What do you mean by encrypted? Password protected wifi (wpa2) or an actual ipsec encrypted network?

Did you check the password is correct (accessible by the router admin page or someone with access can tell you). Do you know what the ssid is or is it already provided (hidden network? )? Do you have problems with any other devices?

Is your network card recognized and supports the protocols used by the router? (A G/N network card may not accept a connection on A/B networks) Does the card support the correct frequency? (2.5GHz, 5GHz)

Is it a wifi 6 router or card?

Forgive me for having more questions than resolutions, but a little more info is needed to assist you.

Any protected wifi, I don't get pop-ups for write password...

I am confused.

Are you using the indicator on the panel to access wifi network choices or are you going through settings?

Like i said in my first post, more info needed.

In terminal paste the output from the following command:
lshw -network

1 Like

And with indicator and via settings...i hasn't parameters such as -network
Did you mean this? lshw -class network

Sorry, i has pop ups...but he is so fast) open and close in microsecond))
I'm about pop up for write password when you connect to new secured wireless network

Using the indicator it should give you a password prompt in the same area as the wifi ssid you clicked on... it isn't seperate, but shown next to the name and replaces the network description and connect button (which gets slid under the input box).

You may want to access settings by the cog in the app menu and click on network tab. You should be able to access networks available in one of the tabs across the top. It's been some time since i used gnome, so do not recall exactly where it is located.

Even when I try to connect through settings, it doesn't give me a place to enter a password. He is trying to connect such like i already connected to this wifi once...

I found my solution)
Turns out in /etc/NetworkManager/NetworkManager.conf was managed=false and i changed it to true and...i have popups))

Nice... I'm sorry i hadn't gotten that far. Glad you got it working.