Cant connect Google Account

Hi, I'm completly new to Zorin, just installed today. I have this problem that when i try to connect google account I always get this error. Can someone help me with this? Thanks for any response

I forgot to add that this happens even before I can type my credentials in, I just click the google account button and this pops out

EDIT: I just tried Microsoft and Foursquare and the same thing happens

Hi and welcome to the forum :slight_smile:

I am not using Google account but when click on that button for Google account, I got this:

Screenshot from 2021-10-23 23-55-50

There is something wrong with your installation.
I wonder is @Aravisian @StarTreker has some idea.

You might have to go to your Google account, and its burried deep somewhere, where you can add your 3rd party accounts there. If you don't Google automatically blocks adding accounts on 3rd party website for security reasons. So you have to manually allow connection. I am surprised Google hasn't emailed you about it yet, cause thats generally their SOP.

I had the same issue when i used zorin 1 month ago. I did update and upgrade via the terminal. Rebooted and it worked somehow.

@StarTreker, google is not the issue because he only pressed the google button and gets that message

3 Likes

Thanks for the tip!
I wonder if @spidysk update and upgrade after the installation.

sudo apt update && sudo apt full-upgrade

Check if Secure Boot is enabled in BIOS settings, as well.

Yes, with Linux SECURE BOOT and FAST BOOT should always be disable for a smooth running OS. And since modern computers come with TPM now, if your TPM is turned on, you might want to turn it off, cause that might be causing issues too.

I've heard that OS 16 is supposed to be compatible with TPM, but I wouldn't chance it, there is no need for TPM in Linux, especially when Linux is own filing system and permissions setup out of the box is far more secure then Windows is lol.

Guys tried everything u recommended but still the same results, and it's not only google, also microsoft and foursquare. I have older PC, it's like 6yrs old and I don't have TPM and I also don't have secure or fast boot enabled. :frowning:

Tpm is not needed for linux, dont worry its not microsoft your dealing with.

Try the live boot session and check if it works in there.

1 Like

Just managed to get to the login screen and after I allowed the permission to GNOME the window just closed and nothing happened, second time I also got the permissions and then the connection refused error popped out again, its weird, why its so random?

Just tried it like 15 times in a row and on the 15th time it worked, thanks everyone for your responses

1 Like

Are you testing on the installed Zorin or USB live session?
If you have not done so, @Michel suggested you to boot into a live session and test online account connection there.

2 Likes

It's strange- on mine the Google account linked immediately and automatically.

It actually bothered me that it did. :neutral_face:

General Note (Not applicable to the O.P.): TPM is essentially a BackDoor Access for a system administrator to be able to access your Computer. There is No Reason to enable it in Linux and it can create a Security Vulnerability if enabled.

4 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.