Can't drag windows to other workspace

While I’m in Activities Overview, if I drag a window over a different workspace, nothing happens. Here is a video showing exactly what I mean.

It works on my Thinkpad T560 running Zorin, but not on my desktop.

I’ve searched around and tried all the troubleshooting fixes I could find on the internet already, but nothing seems to work:

  • Disable mouse click emulation
  • Edge flip move
  • Edge flip pointer

I had taken a break on trying to fix this until yesterday, get this, it just started working for no reason. I made no changes at all that would explain it, but it was working… until the next day and now it doesn’t work again.

It’s frustrating to know that it can work, but won’t.

Any advice on how to make it work and keep it working?

Can you try the keyboard shortcuts to see if they work?

There’s also a suggestion here:

@jgordon recommends Tweaks here: How to get a "new" workspace?
@swarfendor437 has other recommendations here: Install workspaces on zorin os 15

Maybe one of those links helps. If not, feel free to update us.

1 Like

The keyboard shortcuts have always worked (super+shift+Page up/dn) thankfully so I can still use workspaces kinda. It’s just clicking and dragging that hasn’t worked.

It is actually working right now as of this reply, so I’m just never rebooting again lol. Perhaps this bug has been addressed in a recent update (probably not).

Regarding those extensions, I currently have none of those installed.

In your tweaks, is “mouse click emulation” enabled? If so, disabling it may help.


My problem has returned today. I can’t drag to workspaces right now. So weird that this only happens sometimes I boot my machine.

Update. Restarting Gnome seems to fix this problem (temporarily at least until it happens again)

  1. ALT+F2
  2. “r”
  3. <Enter>