Zorin Forum

Can't install Zorin Lite, stuck on "Updates and Other Software"

Hi all, I've been giving small steps into linux since I tried to give life to my old desktop pc. My motherboard is P5LD2 SE, 1gb ram, cpu 1.60 ghz, so It's indeed a 15 years old pc :)) Even though I got stuck on "Updates and Other Software" with Ubuntu and Xubuntu also, I could make it work with them after I found a workaround, I just replaced my vintage ide hdd with a sdd and I make a new partition with Gpart. Hope it helps if someone else is dealing with the same issue. Yes, it played the trick with those distros, but I cannot make it work with Zorin. I've read all the other posts (here at Zorin forum) with similar issues and I think it's because my old pc is not linux-friendly. If you have any idea how to make it work I would really appreciate your help. I'm gonna also try with a little upgrade (cpu and ram). Thanks!

During the installation, can you please uncheck the option to install updates during installation. Run the installation with the updater off, then once installation is complete and you reboot, you can run the updater to receive updated packages.

Thanks for your post, I'm afraid it didn't played the trick, I've tried checking and unchecking all the options (including updates). I've also tried installation without internet. I always get stuck (almost frozen screen) after I click either continue or back on "Updates and Other Software".

Did this computer have Windows (ntfs format) on it prior to installation of Zorin OS?

Nop, I'm only running Xubuntu now, so I have my sdd with ext3 format.

Are you trying to Dual Install?
I highly recommend that you open the gparted partition manager (Either in Xubuntu if Dual Installing or in the "Something Else" option in the Zorin Installer) and reformat the target partition in ext4 format. Then run the installer.
What you describe sounds like a corruption on the disk.

1 Like

I wanted to have only Zorin Lite installed as Xubuntu is a little heavy for my old pc. I'm gonna try giving a new ext4 format and let you know. Thanks a lot, I really appreciate your help!

1 Like

Only 1Gb RAM would be a problem for ZorinOS me thinks.
You say you plan to upgrade that RAM. From what I have just read, P5LD2 SE can take 4GB total over 4 slots.

1 Like

Finally I could make a fresh installation after going around with this issue for a couple of weeks. I reformatted my target partition with ext4 and ext3 format, changed my usd thumb drive, tried new iso images, etc, etc and I coudn't make it work. Then, when I was about to give up I tried with a new wireless keyboard (logitech k400) and it played the trick. Yes, I realized there's something wrong between my microsoft wireless keyboard and linux...

1 Like

Is this the solution, then?

Yes, it just worked when I changed the keyboard :man_shrugging:

2 Likes

A post was split to a new topic: Zorin OS installation Freezingon Updates and Software