Can't update VMware player kernel modules


I can't update VMware player's kernel modules because it returns Exit Code 1

Reinstalling the app doesn't seem to fix the problem. Any ideas?

1 Like

Have you yet tried:

sudo vmware-modconfig --console --install-all

You can also try:

sudo apt install gcc build-essential linux-headers-generic linux-headers-$(uname -r)

If neither of those work, please let us know.

None of those worked. They both return the same error. And now I don't know how to remove the newly installed 5.4 kernel from running the lower command.

In that case, you may need to get the vmware-host-modules in place:

This is mostly a ball that lodged itself firmly in VMware's court and the user is being expected to go in and clean up their mess in this case...

I was able to get into the app alright but now I get this error when starting a virtual machine:

Should we split this topic?

Unless there's something else we can do.

I am not sure, as I am not sure of the cause. I do not use VMWare... and when I have run virtual machines, I chose VirtualBox.
Swarfendor has recommended other choices, as well. In the end VMWare is something I have always avoided.

Have you fully followed the guide provided in this post?

I followed the top guide in the link but not the bottom guide. Was I supposed to follow both guides?

The option was to try to find which solution worked for you.

In that case, I followed the top option.

When I used to use Oracle VM Virtualbox on Windows, it would only allow me to select up to 128MB of graphics when I set up a virtual machine. VMware Workstation Player allowed 8GB of graphics memory for the machines which is why I chose VMware.

Anyway, I'm not sure if VMware (or other people) have fixes for this - I haven't checked yet.

From what I can tell, VMWare does not. Other people do - which I Linked to above. You tried the first one.

Ok, should I try the second one?

Yes, I would try it.

I tried running the second one, but I get the error "Permission Denied" when I try to clone the thing:

EVEN though I have root access.

At the top of the terminal, it shows you change your root password. Was that a separate issue and what you intended to do?

No. I was supposed to become root and I followed this guide because I didn't know how to become root:

I even followed this guide to uninstall the VMware player (which required me to become root) and it worked, so I'm not sure what happened here.

You would enter the password you created when you first installed Zorin and use everytime you unlock your machine.

I am not either.
But you are still having the same initial issue, right?
Or has that been solved, now?

Is that the user password? What would be the command for entering root?

Probably. But I haven't tried again yet. I will do later.