Clicking on Files icon, not opening Files program right away/lagging

Hey all. Been looking if someone else had this weird issue. Only (at this moment) seems to be affecting the Files program, when clicking on said program from Taskbar Favorites (I have the Windows 11-ish theme with the Favorites and Menu in the middle bottom of the screen) it will just hang for about a minute or two before finally opening. Other Favorites on the Taskbar work instantly. Is it something to do with GNOME or Files? By the way, everything is fully updated and this is a fresh install of Zorin Pro 16. Just a reminder, I am pretty new in Linux, even after a year of on and off using it. Would love to move all the way to Linux but most games are still better under Windows right now, sadly.

2 Likes

Another user expressed a similar experience:

You might try:

sudo apt install --reinstall zorin-os-desktop gnome-shell

In order to ensure that all files for gnome-shell and nautilus are installed and configured correctly.
Other than that... I am not sure. I use Nemo FM and it always launches instantly.

1 Like

Thank you. Just did it and restarted Zorin just to make sure. I did make sure all was updated before I did the above. So far, it appears to have worked. If the same issue happens, maybe removing and re-adding the icon back in its place could help? I am thinking of Nemo as well. Loved it on Cinnamon DE.

I have had a bug where software store wouldn't launch, and thats because there was already an instance of it running in the background. Using the Stacer app to kill the process, allowed me to start it up later. This did not happen on Zorin OS though, however, it sounds like a very similar situation.

And of course, sometimes, a simple restart fixes many issues. Hence the classic IT solution, have you tried turning it off and on again?

1 Like

I wouldn't think so- the launcher on the panel is not really relevant to the launch time.

You can install it and set it as default on Zorin OS very easily.

:laughing: Yes! Yes I did! lol And it would come back after the restart. So far, still doing good. after doing what @Aravisian said to do. :crossed_fingers:

It be honest, I am just holding out for Pro 16 Lite. I LOVE XFCE much more than GNOME. I like the idea of some things in GNOME but it and KDE are the only 2 DE's I usually have problems with later on using my PC. XFCE has ran without problems for me on every distro that it is default on. Now, if I manually try to install XFCE on a distro with something else as default, then I have problems. I just wait until Lite is released and reinstall my Zorin then. :wink:

1 Like

I installed XFCE on Zorin OS 16 Alpha and never had problems.

1 Like

Yeah but you are smart. I am a caveman using my club on Linux and trying to pull it by the hair to my cave. :laughing:

But seriously, I have done many times installed XFCE on a distro with something else as default and had problems with dub apps, extra apps for XFCE and GNOME. Some errors in updates because of of GNOME and XFCE programs together and I don't know what to remove and what to keep.