Clock Settings - How To Update/Change

Can't change the clock settings. Apparently others have had some problem.

Any help is appreciated.

Many thanks in advance.

1 Like

"Can't"? Does this mean you can't find where to change the clock settings? Or when you try to change the clock settings you get some sort of error message? Also are you on zorin os core or lite?


On zorin os core, you would open the Settings app and click on the search thing on the top left, search "time" and open the "date & time" section. From here you can change the timezone, time format, and set a specific time if needed.

1 Like

I'm on Lite and after I go through the above the time still won't change.

I don't know what it could be.

Many thanks in advance

1 Like

@Stanko1 Could you please update your forum profile to indicate to us that you are using ZorinOS Lite. That will reduce teh need to repeatedly ask you which OS edition you are using.

I do not have Lite, but are your Regional settings correct for your timezone.


On Zorin OS Lite, right click the clock on the panel and select Properties
In the properties window, click Time and Date Settings

If you do not have the clock on the panel:
In the app menu, click Settings
Scroll to the bottom of the Settings window to Time and Date


Maybe this is a stupid reply but maybe you can't change date and time on Settings > Date and time because Automatic date and time is enabled, only after disabling it you can change date and time manually.

Did it manually earlier to no avail.


1 Like


And setting are all good.

Weird. And Many thanks.

1 Like

Already tried.

Many thanks and sorry for the bother.

I'll just leave it be.

1 Like

If that is not working, let's check my trick for cheating on Fallout Shelter.
Is your output in terminal correct for:


Ensure youa re in the right timezone:

timedatectl list-timezones

You can set time in H(our):M(inute):S9econd) format (replace HH:MM:SS with the actual hours mins and secs)

timedatectl set-time HH:MM:SS

1 Like

I just wanna put this here just in case someone is having the time problem especially they're dual-booting Windows and Linux.


I got:

Failed to parse time specification: HH:MM:SS

I give up, thanks to all and Merry Christmas. Sorry for this ridiculous problem.

1 Like

I am sorry, I was not very clear there.

you must replace the "HH:MM:SS" with the actual numbers:
For example:

timedatectl set-time 05:55:30

1 Like

Ever thought about using Remmina to connect directly to someone? Because if here on the forum it's hard to fix something maybe connecting to the pc in troubles you can take a look personally to be sure not forgetting a step on the check. Then if it's impossible to change date and time neither from settings nor from terminal (and excluding a damaged file or virus/software action) I'd think that BIOS/UEFI is blocking somehow, if it's possible.


While those of us who try to help on the forums must jump through extra hoops - I could not imagine trying to remotely connect to users much less the major can of worms that could open.
With a trusted friend or family member - perhaps. With strangers, especially those who may have an innate distrust of all other strangers - it just begs to not end very well.


I did that and still didn't work.

Tried a few more times and it came back normal after it rebooted. Weird.

Many thanks once again.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.