Computer doesn't power off

Hi, I have installed Zorin Core 15.3 and everything works fine. However, I cannot power off the pc: I click the turn off button, the screen goes black but then it never shut down.
My pc it’s a bit old: is an HP Pavillon P6, with 8 GB RAM and an AMD A4-3400 64 bit.
Is there anyone who can help me?

Can you check Settings->Power to see if “When the Power Button is Pressed” is set to Power Off?

Yes, it is set correctly.
The issue relies somewhere else: it seems that the hardware does not shut down. When I press the button Zorin seems to shut down but then it get stuck in a black screen.
It happens the same if I put it in sleep mode

Press alt+F2 and type dconf-editor in the box that appears. If you don’t have it, use sudo apt install dconf-tools (in terminal, ctrl+alt+t) to get it.
Do two searches, one for “button-power” and one for “power-button”. You should get one result for each. Turn off the default value for one and see if it works, if not, return that one to default value and turn off the default value for the other. Try again. If still no luck then turn off default value for both and try. That way you’ve tried all the combinations that those two can address. See if that fixes it.

Thank you for your help. Unfortunately none of the combinations works :frowning: .
If you have any other suggestions I will gladly try them. In the meantime, I will press the physical button to turn it off lol.

In the interim, you can use sudo poweroff from the terminal.

Try these suggestions, in order (don’t try #2 if #1 works):

  1. Using Synaptic, reinstall the package gnome-power-manager. Restart and see if that did the trick.
  2. In terminal, type sudo nautilus (make sure Synaptic is closed). When the folder opens, press ctrl+L and then in the field that opens, enter /etc/systemd and press Enter. Open the logind.conf file. Delete the # in the line #HandlePowerKey=poweroff. Save the file. Close folder and Terminal. Restart. Test.

Well, I didn’t thought about using the terminal to power off the computer: I tried it and the command didn’t work :grimacing: . However I tried both your methods and nothing happened.
I’ll keep looking for a solution. Thank you for your help in the meantime!

Please try systemctl poweroff

Hi sorry for the late reply. Well, as you can imagine, it didn’t work. I guess my computer doesn’t like linux :expressionless:

Did your machine have Windows on it (or still does as dual boot)? indicates a Windows related issue.
If yes, then there is a method (in addition to the one on the prior link) on disabling the likely cause listed under #4 here USB boot install if it helps.

I realize that you said your AMD is a bit old… but these days, old is relative.
Is your machine UEFI?

If so, you may need to add the parameter



You can do this from terminal with

sudo nano /etc/default/grub

Arrow key down to the grub cmdline linux default and add the paramater. If there are already items in there, you can separate with a space, for example

GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash apm=power_off”

Hi @carmar! There was Windows 10 on that pc, but after some trouble I wipe the entire system and installed Zorin Core. Thus I don’t think that link will work.
@Aravisian, well it’s old for my standard XD. Yes it is a UEFI machine. Unfortunately even your suggestions failed.

However, today I tried with the suspend button and in this case we moved forward: this time the pc seemed to actually suspend. The screen turned off. Well, then it didn’t exit the suspension mode. Again, I have no clue what’s happening.

Well don’t worry guys, we will either keep using the physical button or we will look for other distros. Thank you so much for helping me during these past weeks.

Are you using a Nvidia Graphics card? Otherwise, are you using any proprietary graphics drivers?

No, I have an ATI Cedar Radeon HD 5000/6000/7350/8350 Series. No proprietary drivers installed.

Dated article but may be worth a try:'t-shutdown-properly-686656/