Cry for help! Black monitor after Wayland restart?!

Hello all, I'm afraid noob alert with a big cry for help!

So quick story....

Switched from Macos to zorin on my macmini2012... Friday installed zorin as a clean install on my system drive. All went fine and began installing my software options, due to a few issues I hit I decided this morning to do a new clean install on zorin to start fresh from my learnings.

Again install went fine, I installed all the zorin updates on first boot and also enabled the broadcom WiFi adapter to connect WiFi. Restarted fine.

My next job was to install realvnc server from their website download to allow me to connect remotely. Install went fine and at the end was asked to disable Wayland for realvnc to work and restart so I did.

BUT now although my monitor comes to life I cannot see anything? In a panic I tried to reinstall from usb again but I can't even get my boot menu to appear on screen? Just nothing apart from the monitor backlight!

Now I know my zorin is booting ok as I can connect via realvnc from another device, my concern is though if I reboot the MacMini and realvnc does not autostart (one of my first issues) I can't even get on the device via connected monitor to enable it or even reinstall via usb?!

Please can someone help why I have the remote connection too resolve this issue!

I am ready to throw it all out the window as I can't read anymore advice via Google I am in desperate need of some conversation to help

Please please :pleading_face:

Did the Program disable Wayland or did You that?

So, you have access, yes? When You are on the Login Screen click on your Account and the Password Field appears. Then look in the bottom right Corner. Ther should be a Gear Icon. Click on it there You shoud have the Options ''Zorin Desktop'' and ''Zorin Desktop on Xorg''. Look if You can choose the Xorg Option - that is the Non-Wayland Desktop.

1 Like

At the end of the realvnc install it advised I disabled Wayland to allow connections which I said yes to and it then asked for a restart. (This was the same on my first time round as well but did not cause this black screen problem)

I have just looked and no gear icon at login just a power and WiFi kind of menu available.

I can login fully from a secondary device via realvnc so have full access that way round.

Just not via the monitor connected to the actual pc?

Maybe you can check if realvnc changed the settings in /etc/gdm3/custom.conf

As default line number 7 should look like this:
#WaylandEnable=false

But if it looks like this:
WaylandEnable=false

Then I think you could try to comment it out again by adding # in the front, then reboot the computer, and then look if you have a "gear icon" in the bottom right corner when you click in the password field.

2 Likes

Hmm ... Okay, You could try it with the Suggestion from @emit.

If You have more than one Posibility to plug-in Your Monitor, You could try the Monitor on a different Port to see if there is a Picture.

1 Like