Dell 3180 Chromebook, No sound. Zorin 16.2 Core

I can't seem to get any sound after installing Zorin OS 16.2 Core
And it's nothing something stupid such as the sound is muted or the sound slide control is so low its practically off
The problem is Zorin
There is so many releases of Linux I probably shouldn't waste my time but Zorin is much more familar to me as I come from a Windows backgroup so it's just a lot easier to use then other Linux Distro's

I did try Lubuntu 23.04 and the sound works just find but Lubuntu isn't Zorin so I wiped the drive and installed Zorin 16.2 again
But again still no sound

I installed the PulseAudio Volume Control app but that did nothing (still no sound)

I also installed all the Zorin updates but still no sound

I'm also using a Dell 3180 (which is an 'end of life' Chromebook)

Here, try this- someone happened to post this fix few hours back.

1 Like

If that does not work.

There is also Linux Mint Cinnamon you could try. While I personally prefer Zorin to it for various reasons it does have a lot of great things about it as well. It is also pretty similar to Windows

You can also try these suggested fixes: GitHub - rgvxsthi/Braswell-EDGAR-Linux-Fixes: Fix sound and other essentials on Braswell-based Chromebooks running Linux

In the meantime, can you please post the terminal output for

sudo lshw -C multimedia

so we can see which drivers you are using for your sound card and their configuration?

tech@tech-PC3:~$ sudo lshw -C multimedia
[sudo] password for tech:
description: Video
product: Integrated Webcam
vendor: CNFFH36N45641027E802
physical id: 4
bus info: usb@1:4
version: 65.10
serial: 0x0001
capabilities: usb-2.00
configuration: driver=uvcvideo maxpower=500mA speed=480Mbit/s
description: Audio device
product: Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller
vendor: Intel Corporation
physical id: 1b
bus info: pci@0000:00:1b.0
version: 35
width: 64 bits
clock: 33MHz
capabilities: pm msi bus_master cap_list
configuration: driver=snd_hda_intel latency=0
resources: irq:315 memory:91314000-91317fff

Can you please try the following Grub Parameters:

sudo nano /etc/default/grub

For the line

Change it to:
GRUB_CMDLINE_LINUX_DEFAULT="i915.disable_power_well=0 quiet splash"
Tap the keyboard shortcut ctrl+o to overwrite, then the enter key to save current configuration. Tap ctrl+x to exit the editor.
Now run

sudo update-grub

Reboot and test sound.

Tried this (and rebooted laptop) but still no sound

Wow, my batting average this week is dismal...

You can undo the change above and re-run sudo update-grub to make it take affect.

Can you please check your BIOS Settings for any configurations for Integrated Sound?

I was trying to following the steps in the video but I can't seem to use "su"
No matter what password I enter I get "authentication failed"

screenshot - su - auth failure

Use sudo instead of su
sudo=SuperUser DO (as in, DO this)...

In the video it shows entering just su then hit enter


I tried sudo and hit enter but I just get a list of parameters to enter

How would I switch to root ?


Ah, sorry. Someone else had posted the video - I have not watched it.
To elevate to Root on Zorin OS, in terminal run:

sudo -i

Getting closer
The command "sudo -i" gave me root access

I'm not trying to run the command "make menuconfig" but I'm getting the error "gcc not found"


sudo apt install build-essential

Will install GCC. You can do that and try again

I had pretty much given-up trying to get sound on my Dell 3180 Chromebook and started looking at other distro's

When I searched for "Atom/Celeron/Pentium Processor x5-E8000/J3xxx/N3xxx Series High Definition Audio Controller" (which is the Sound adapter this old Chromebook has), it seems no one has been able to get sound from this sound card using any distro based on Ubuntu

So I installed Fedora 38 and behold sound works pefectly (at least when I use YouTube)

The problem I having with Fedora is: When I try to run a Commodore 64 game using the Vice emulator it's very choppy (slow)

So I'm heading back to Zorin again as the Vice emulator run C64 Games very well (smooth and very resposive)
The only problem is: I can't get Sound using I use Zorin

But of all the distro's I've tried, Zorin is still the best

So I'm back to trying to get Zorin to produce sound on my Dell 3180

Give Nobara/Ultramarine a shot as well. They are based on Fedora but have some non-free drivers by default that might help you.

Have you yet tried:

sudo apt install linux-firmware


lspci | egrep -i audio

And relay the result here, please.
You should see something like sof-xxxx####

Open Alsa mixer elevated to Root

sudo alsamixer

tap F6 to select your card that you identified above.
Now, in a terminal window, run

sudo alsactl store

Reboot and test...

There is only two to select
Whether I select 0 or 1 I get no sound

Also, is there some way to "save" the selection ?
Or do I just exit ?

Yes, exit with your selection chosen, then save it with

Choosing 1 should be the correct method.
You might try installing the NonFree Firmware

I tried to run an intall by double clicking the .DEB file but I ended-up with the following error:

"Unable to install firmware-intel-sound:
Error while installing package: trying to overwrite 'lib/firmware/intel/-intcSST2.bin', which is also in package linux-firmware 1.187.35"

I also tried to run the install from Terminal but received a similar error