Different boot, different HDD/SSD icons and order

Hey there guys,

First of all I'm happy to be back at Zorin! After trying out a bunch of other distros, this is #1! But as with anything in life nothing is perfect.

Sorry if the title of this thread is a bit unprecise, but so is the issue.

It seems like I have 2 different ways my Zorin installation boots (No, I don't have dual boot or anything similar installed) and it's working flawlessly, but I was just wondering why the following is happening.

Sometimes when I reboot Zorin I have a bootlogo (The Zorin OS one) and sometimes I don't.

In case the bootlogo is showing at boot, my hard drives order looks like this:

Weird Drives 1

As you can see the internal HDDs/SSDs are not listed at "On this computer", but are listed on the overview in the file manager app (Picture one). Even the EFI partiation is listed there.

In case the boot logo does not show up while booting, the internal drives are all not in the file manager overview, but in the "On this computer" tab.

Besides that everything is working great either way, but I just wanted to know why this is happening or if it has to do with an error in my installation? Or does it simply not matter? Still, why is this happening in the first place?

I hope you get the catch of my problem and any information/help would be greatly appreciated.

Best wishes to all of you,
André :slight_smile:

How often does the second (Non-logo) boot happen? It looks like the drives are not automounting.

I'd say it's 70/30 in favor for the with-logo-boot. I have many drives attached to the computer

Yes... I uh... I see that...
There may be drives that are attached that have EFI partitions remaining on them from past activities.
And it may be a connection with one of the drives, too.

I see I see, mhhh.

Can you tell me if either booting is good/bad or can I just keep using my installation with any boot (with logo and without?). Furthermore, do you think I have to delete the EFI partitions to get rid of the "issue"? Or what would you recommend, if anything, in my situation?

Here are screenshots when it boots w/o logo btw:

Weird Drives 4

It doesn't look dangerous, really. Just annoying. Of course, always perform regular backups of all your personal data.
IF you feel inclined, you can check each Drive and see if it has any EFI partitions. You may need to ensure first that you know exactly which EFI partition on which drive you are actually using to boot.
You can reference that with your fstab file.
If you find any extra EFI partitions, you can delete those partitions using gparted and either leave the free space (not much space) or reclaim it.

1 Like

Once again, thank you Aravisian!

Just for my mind's sake: I would use the Zorin OS built-in Hard drives tool to delete those EFI partitions, it will be easy to determine the EFI partition I mustn't touch.

However, I just noticed almost all drives I have connected still have EFI partitions on them. Pretty likely a Windows thingy, as I had previously Win installed too.

Here comes my question:

Is it really safe to delete those EFI partitions without losing the data on the drives? As I'm running several TBs worth of data, this is an essential information for me :slight_smile:

With computers... I never like to give any guarantee...
The situation is: EFI Partitions deal only with holding the files for the Bootloader. They are irrelevant to the Data on a different partition.
You can think of and most often treat a partition as its own independent drive.

Alright sir, shut up and take my terminal :smiley:

At it, will report back soon :slight_smile:

So deleted all 17MB/EFI partitions and will reboot now :slight_smile: Fingers crossed!

1 Like

The good news is that the data is all there, the bad news is that it didn't solve the problem :smiley:

Still no boot logo-boot now, but drives in correct order

Run sudo update-grub
and maybe (though shouldn't be necessary) sudo update-initramfs –u

1 Like

The last one's printing:

Extra argument '–u'

Usage: update-initramfs {-c|-d|-u} [-k version] [-v] [-b directory]

-k version Specify kernel version or 'all'
-c Create a new initramfs
-u Update an existing initramfs
-d Remove an existing initramfs
-b directory Set alternate boot directory
-v Be verbose

See update-initramfs(8) for further details.

Any thoughts?

Not rebooting now again, as I'm glad everything is (still) working and running :smiley: But will surely report on the next boot cycle :+1:

1 Like

No. That doesn't make sense. It offers up the very command it says is an extra argument.
Perhaps there was white space in your command.

Ah! I copy/pasted your command and you used a different hyphen. Worked after manually typing the command :+1:

So, if your suspicion is correct, the next boot would be with a logo and the file system sorted correctly, amirite?

I'm totally curious if it will work now! However, still having some major background tasks running, so won't reboot rn, but definitely will report on the next boot cycle.

So far already grateful for your help! If it works: Double win :slight_smile:

Have a great evening, Mr. Aravisian sir :heart:

EDIT: Oh! Does it make a difference if I expand the existing partition to the newly created free space? (After deleting the EFI partitions?). Because I did not, I just let those 17MB of free space sit there. What are 17MB nowadays :smiley: Also, don't wanna break anything just to get 17MB more space per drive ^^

No, you will just end up wasting allll that free space. You wretch.

I feel that way with most of my posts...:pleading_face:

Yep. Fingers crossed... and toes too.

Lmao! Can't believe you're lying right to my virtual face! You can't cross your toes! I feel righteously offended, report's being send!

Your posts and advises are like a car ride with a very drunk monkey in the driver's seat. The car will shake and stumble a lot, but you will arrive on the destination without ever being really in trouble :smiley:

Yeah you gotta have the attitude to come at me like that after being exposed as a liar huh? :angry: jkjk :joy:

1 Like

Prove that I can't cross my toes. :wink:

1 Like

Prove the opposite :cool: Pics or it didn't happen insert troll face here

Edit: How did we get here from sudo commands? :joy: Holy :joy:

1 Like

Hey there,

A small update. As you've seen I have quite a bunch of HDDs connected to the computer. I've been going crazy today about it, as multiple drives randomly kept on disconnecting, reconnecting, disconnecting, reconnecting...And no reboot, neither of the computer, nor the HDD cases seemed to solve the problem.

That's why I now disabled CSM Support in my BIOS and now I had a boot logo and the drives ordered "correctly" for the first time. The system is stable too. That's why I opened this thread asking for CSM recommendations to verify my assumption.

However, as this was going on for the past 6 or so hours, I'm still a bit skeptic.

In general, if anybody is familiar with multiple HDDs in 4-/8- and 10-bays, I'd soak up any insight you might have, as it's pretty annoying to reboot the computer every 5 minutes due to an HDD I/O error or similar (All bays are connected through USB 3.0 or Type-C directly to the motherboard).

It's a little bit off topic, but my guess is that the no-boot-logo/yes-boot-logo situation, drives and their partitions + CSM support are all tangled up together.

Have a great day wherever you are. I keep praying that there won't be the next HDD failure just around the corner ^^

EDIT: Ah wow! Awesome! Now indeed all HDDs work, but they're all not mounted where they used to be :joy: :joy: :joy: What the actual heck is going on :weary:

i.E., what used to be /mnt/Volume6/... is now /mnt/Volume2/...
and /mnt/Volume3/... is now /mnt/Volume4/... :joy: and so on :joy:

Meaning nothing is where it used to be, which is pretty much the worst case scenario.

Holy mother of God... :sob: Something in my setup is just very, very wrong :cry:

1 Like