Difficulty reaching the desktop

I am retired computer operations operator using a older model Apple MacBook Pro installed with 2 partitions on 1-500GB disk. One partition has Zorin 16 Lite and the other Linux Mint. Currently I am logged in to Zorin but even after running boot repair, have no start up menu and no idea how to log in to the Linux partition.
I've tried editing the grub file directly in an effort to get the menu to show up at boot but seems it did not affect anything.
System constantly boots to Linux until I run boot repair to get the system to boot to Zorin but never see a menu.

Here is contents of /etc/default/grub file:


If you change this file, run 'update-grub' afterwards to update

/boot/grub/grub.cfg.

For full documentation of the options in this file, see:

info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

Uncomment to enable BadRAM filtering, modify to suit your needs

This works with Linux (no patch required) and with any kernel that obtains

the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)

#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

Uncomment to disable graphical terminal (grub-pc only)

#GRUB_TERMINAL=console

The resolution used on graphical terminal

note that you can use only modes which your graphic card supports via VBE

you can see them in real GRUB with the command `vbeinfo'

GRUB_GFXMODE=640x480

Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux

#GRUB_DISABLE_LINUX_UUID=true

Uncomment to disable generation of recovery mode menu entries

#GRUB_DISABLE_RECOVERY="true"

Uncomment to get a beep at grub start

#GRUB_INIT_TUNE="480 440 1"

GRUB_THEME=/usr/share/grub/themes/zorin/theme.txt


I've tried modifying line:
GRUB_TIMEOUT_STYLE=menu
changing =hidden to =menu
but don't see any results or changes at boot.

Can anyone make suggestions or help with my problem?

Thanks!
Thomas B.

Have you tried tapping the esc key or tab key or using MBR (Legacy), the left shift key with vigor, once you see the Motherboard Splash Screen?
See if you can get the advanced menu up - then select which to boot into. I believe you are trying to boot into Linux Mint... Once in, open terminal and run

sudo update-grub

ESC key causes system to hard freeze. Left Shift key did nothing. System booted as usual. No boot menu, no option to boot into Linux Mint
Any other options ?

Thanks !
Thomas B.

I would reinstall grub at this point, then: