Disabling content of personal folder on desktop?

After searching for some files, I somehow must have enabled the content of personal folder to be displayed on desktop.
That also means, if I add folder or file on the desktop it also appears in the personal-folder as well.
How can I make the content of personal folder disappear from the desktop.
Deleting anything from the desktop, deletes it also in the personal folder.
It seems, as if the setting of the Desktop has been changed to be the same as the personal folder. But I've got no idea on how to change it back.

Edit ~/.config/user-dirs.dirs file and set the location you want in XDG_DESKTOP_DIR.

To edit this, open Terminal application, type this command and press ENTER:

gedit ~/.config/user-dirs.dirs

XDG_DESKTOP_DIR="$HOME/Área de Trabalho"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Modelos"
XDG_PUBLICSHARE_DIR="$HOME/Público"
XDG_DOCUMENTS_DIR="$HOME/Documentos"
XDG_MUSIC_DIR="$HOME/Música"
XDG_PICTURES_DIR="$HOME/Imagens"
XDG_VIDEOS_DIR="$HOME/Vídeos"

In this example XDG_DESKTOP_DIR are pointing to $HOME/Área de Trabalho (my Zorin is in Portuguese)

PS: I think you will need to log out and log in again for these changes to take effect.

Well, I found a file users-dirs.dirs. I looks just like yours.
So, just in case, I made a copy : user-dirs.dirs
checked it once more and made a restart. No change :frowning_face:

Does the "$HOME/Desktop" folder exist? Wouldn't it have been deleted by accident?

Try this command in the terminal to see if it lists the content
ls $HOME/Desktop

When I check the different folders on the desktop, like : Musik
it shows me the directory above : /home/erwin
which is OK.
Comparing the setting with another Linux-System it is OK.
With one difference : other systems show only the content of the folder Desktop,
while this one shows the folder Desktop (I added it again, because it had disappeared) plus all the other folders ( Pictures etc. )
I just found, that I had moved Desktop to Templates
I copied the original back to /home/erwin and deleted the newly created plus I restarted the system. No luck :frowning_face:

ls $HOME/Schreibtisch shows me the content as it was before this issue

If I create a new directory now on the desktop, it doesn't correspond to /home/erwin/Schreibtisch as it would be expected, but only to /home/erwin
Therefore there must be a way telling the Desktop (via right click ?), that it has to correspond to /home/erwin/Schreibtisch

The content of the /home/erwin/Schreibtisch doesn't show up on the Desktop

It must be because Desktop is pointing to the /home/erwin folder and not the Desktop folder inside of this folder /home/erwin/Desktop.

What your folder structure should look like:

--- /home/erwin
            |----- Desktop
            |----- Music
            |----- Downloads
            |----- Templates
            |------ . . .

And config file:

XDG_DESKTOP_DIR="$HOME/Desktop"
XDG_DOWNLOAD_DIR="$HOME/Downloads"
XDG_TEMPLATES_DIR="$HOME/Templates"
XDG_MUSIC_DIR="$HOME/Music"
. . .

Note: $HOME = /home/erwin

Thank you very much.
Everything is now again as it should be.
Have a nice day :slight_smile:

1 Like

If macfly's post is the solution, can you click in the :ballot_box_with_check: Solution marker for that post. Thanks.

EDIT: I moved "Solution" marker from here, to mcfly's post where I think it belongs.