Discord Missing Notification Badge in Taskbar/Dock

I've just switched to Zorin 16 Core from Ubuntu 20.04.3 LTS, and I'm loving the switch so far. I've gotten everything set up as I liked so far, but there's one inconsistency that's bugging me that I can't figure out.
In Ubuntu, unread Discord notifications appear as a small number in the dock and with a small red dot in the app indicator. In Zorin, however, only the app indicator shows unread messages; nothing in the dock.

This is a stock Ubuntu 20.04 VM with just Discord installed and the unread messages badge.
Screenshot from 2022-01-11 22-55-12

This is my Zorin 16 dock with the same Discord account and same unread message. The only external GNOME extension I have installed is Dash to Dock. I'm using the first layout option with Zorin Taskbar and Zorin Menu disabled.

I've tried a bunch of botched GNOME extensions and layout fiddling and internet hunting and haven't been able to find a solution. I'm not sure if this is a theme issue, a GNOME shell issue, or what, but I'd appreciate if anyone could help me figure this out.

How did you install Discord on each of Ubuntu 20.04 and on Zorin OS?
On Zorin OS, the Software store shows you a "Source" button on the headerbar when you select a program in the list. You can check that to see what source was used for Discord if you need.

I used the .deb package for both Zorin and Ubuntu, downloaded from Discord's webpage. I also tried installing Discord via flatpak on Zorin but was met with the same results.

I've also tried the .deb package out in a stock Zorin OS 16 Core VM and no badge, just in case something I installed manually might be conflicting

I think it's somehow built in Ubuntu dock. Try to install Ubuntu Dock from extensions.gnome.org and disable zorin taskbar.

The Ubuntu Dock GNOME extension details This a mock extension. It does nothing if installed from extensions.gnome.org. The extension does seem to be built into Zorin, however.
Disabling the Dash to Dock (where it's installed) and Zorin Taskbar extensions and enabling the Ubuntu Dock extension does not resolve the issue, on either my setup or in a stock VM.

After some more testing I'm fairly confident in saying this is not a base GNOME issue. I noticed that Ubuntu 20.04 ships with GNOME 3.36, where the indicator worked, and that Zorin OS 16 ships with GNOME 3.38. I thought this might be the issue, but after setting up a VM with Ubuntu 21.04 (it ships with 3.38) the notification badge worked just fine. I'm pretty certain at this is a Zorin issue. Is there an older release of Zorin that ships with 3.36 that I can test with?

Other bits of testing to note:

  1. Switching between Xorg/X11 and Wayland yields no solution (tested because Ubuntu 21.04 uses Wayland by default)
  2. Disabling all extensions yields no solution
  3. Mimicking Ubuntu's extension suite yields no solution
  4. Resetting all appearance options to default/Adwaita yields no solution

I'm pretty much at a loss here of what to investigate next. This feature isn't critical to my daily usage, but it's certainly nice to have and I'm honestly really curious as to why this discrepancy is present.

1 Like

Does the badge show notification count when used on the Gnome-Shell panel? Or does it not show the count ether it is in the dash, dock or panel?

EDIT: I should probably backtrack and explain the reasoning behind this question...

While I do not doubt you in any way, this raises questions all on its own; as the Dock is managed entirely by a gnome-extension.
I would quickly wonder if Ubuntu is using a different extension than Zorin OS is using.
I do not use the Default Discord app, but prefer Better Discord:

I also use Zorin OS Lite... So I cannot quickly set up and test this at the moment.

It shows up nowhere in Zorin OS. In Ubuntu, it shows up in the default installed Ubuntu Dock extension, but not in the panel (extension disabled).
This would lead one to believe that your line of reasoning is the culprit; the dock extensions are different. As I said earlier, Zorin OS does in fact ship with the built-in Ubuntu Dock extension, but enabling that does not fix the problem.
Interestingly enough, Ubuntu Dock seems to be an alias for the Dock to Dash extension! Both point back to the same source: Dash to dock GNOME Shell extension
Then my question became why does the same extension (or 2 extensions rather) not yield the same behavior between Zorin and Ubuntu? I did a lot of tinkering, even to the point of manually copying an replacing files in /usr/share/gnome-shell/ and not once could get the notification badge in the dock.
(I did install Better Discord just to check if it somehow could fix the badges. No luck)

1 Like

I use Zorin OS lite, so I do not deal with Gnome-Extensions very much.
Zorin OS Core includes features to help Zorin OS Desktop assist the user and these include certain Zorin Extensions.
On the surface, these extensions may seem to be the Same Extension as found elsewhere... Like Magic Lamp... Zorin-connect... But when they have a Zorin name attached, it may mean that extension has been modified for use with Zorin OS. So, the appearance of being the same may not mean that they are exactly the same.
You might try uninstalling the Zorin Extension, then installing the extension as it appears in Ubuntu and testing that way.

I did try that, when swapping contents of /usr/share/gnome-shell/ between Ubuntu and Zorin. I'm also not working with any Zorin specific extensions for GNOME, only Ubuntu and user-installed ones, although as I detailed that distinction matters little in this case. To elaborate on that, the description for Ubuntu Dock reads

A dock for the gnome shell, default ubuntu experience. this extension is a modified version of dash to dock with different defaults. dash to dock can be installed to replace it and give more (but unsupported) configuration options.

I've tried both Dash to Dock and Ubuntu Dock with no results. The only sensible conclusions I can reach at the moment are: Zorin 16 ships with GNOME 3.38.4 and Ubuntu 21.04 with GNOME 3.38.5, so this minor release could be the culprit, although no changelogs seem to support this, or Zorin 16 is having trouble displaying these badges for whatever reason.
My suspicion is towards the latter.

Given your observations, I think you have good reason.
I am going to try tagging this for @AZorin and @zorink (ZorinGroup) to review.
Quick Summary:
Discord not displaying Discord Badge Notification Count on the Dock.

1 Like

Marked solution. 239

Why was this marked as a solution?

My mistake.
I assumed, based on your post that you've moved on.
If you have not, then based on this, I doubt there will be a resolution to your satisfaction.
Would you like to leave a note that there is no resolution? This is for the benefit of future readers.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.