Discussing Zorin Forum [How to] Fix “System BootOrder not found” error

Your boot order makes use of shimx64.efi. This suggests that you are performing a dual boot with a windows os. Please confirm.

No, it is not a dual-boot setup.
This laptop (HP Elitebook) only has Zorin on it and never had any Windows installed on it.

Just out of curiosity, I also checked the content of cd /boot/efi/EFI/ubuntu on my desktop which never had Windows nor dual-boot. (This desktop never had this “System BootOrder not found” error)

ls cd /boot/efi/EFI/ubuntu

the output clearly shows shimx64.efi
BOOTX64.CSV grub.cfg grubx64.efi mmx64.efi shimx64.efi

After installing Zorin I found it to work flawlessly, sound, usb, wifi, etc. all worked without problem. The only glitch was booting. A majority of the time it boots but on occasion it stops with a black screen. I launched sudo thunar and reviewed the contents of partition efi. It contained two folders , boot and ubuntu. I selected efi/boot/bootx64.efi which seems to give me the most direct route to launching Zorin. I googled mmx64.efi, grubx64.efi and shimx64.efi and all seemed to be suited to addressing the potential problems with secure boot. I have secure boot disabled as I only have Zorin installed. I look forward to the benefit of your wisdom.

You can use

journalctl --list-boots

to list your boot logs. This will show by date - so you can select the one that is a Failed Boot.
You can then view it with:

journalctl --boot=(The Boot Log Identifier)

So, for example, let's say the log you want is from 2021-06-17 08:00:00 PDT. Look at the beginning of that line and you will see a - minus sign and a one or two digit number, then a space, then a long sequence of letters and numbers. That Long Sequence is the Identifier. You ONLY need the identifier, so yours may look like:

journalctl --boot=bc6a5d7dd94d44e9800cc57d58c1235e

This will print out the log for you to review or to paste on the forum to see if anyone can find a fault that may lead to booting only to a black screen.

I had this problem on the desktop.
I solved it by changing the following 2 settings in BIOS

  1. Disable CSM (Compatibility Support Module)*
  2. Change boot order to make the internal drive to be the 1st one to boot**

*Disabling CSM simplifies the boot sequence and reduces the possibility of boot failure.

**This prevents the system trying to boot from other connected drives devoid of OS. This situation could cause a black screen with a blinking cursor (system hang).

1 Like