Display freezing/low refreshing, after turning on monitor with Display link

I want to add third monitor to my computer via displaylink adapter.
I installed drivers from there:

In terminal when i put: lsusb i got:
us 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 005: ID 17e9:02ee DisplayLink VGA Display Adapter
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 0e6a:02c0 Megawin Technology Co., Ltd PS/2+USB Keyboard
Bus 004 Device 002: ID 04d9:a09f Holtek Semiconductor, Inc. E-Signal LUOM G10 Mechanical Gaming Mouse
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

So displaylink is there.

but when i go with: sudo ./displaylink-debian.sh --debug

I got msg: sudo: ./displaylink-debian.sh: command cannot find

My graphic card: Radeon HD 6450.

Two monitors work normal.
When i run display link 3rd monitor, display start freezing or refreshing is on very low level. How can i overcome this issue?

How many watts is your power supply?

I should add that this configuration with displaylink works fine on Windows. Previosuly i was testing ubuntu and had same problem with "freezing".

Did you install the AMD Drivers?
Closed Source drivers are incompatible with Display Link and you must use Open Source drivers.

Does your issue sound very similar to any of these posts?

No, my display works, system also works but whole movement of mouse is very low like in slowmotion, also every aplication open very slowly if displaylink is conected.

I did not install any ATi Radeon HD6450 drivers, so system has graphic drivers that came after instalation.
If that would be an issue, what drivers should i use for my graphic card?

The open source drivers are included in the Linux Kernel, so it sounds like that is what you are using.

Ok, so it is not freezing but everything is sluggish?

I don't think you would be able to since that card is...a museum master piece :sweat_smile:

Maybe should use the LTS 5.4 kernel then?

Sorry, but don't understand (new to linux). Zorin 16.2 has 5.15 LTS kernel as i googled it, so i would not able to use displaylink with Zorin? Best Regards

I agree, yet works fine with Windows and my attempt to go with linux doesn't look like fairy tail :slight_smile:

You can install the 5.4 kernel:

sudo apt install linux-headers-5.4.0-81-generic linux-modules-5.4.0-81-generic linux-modules-extra-5.4.0-81-generic linux-image-5.4.0-81-generic

Once installed, reboot and start tapping the esc key when you see the motherboard splash screen to pull up the grub menu.
At the Grub menu, select Advanced Options for Zorin
Arrow key to Zorin on 5.4.....
Hit the enter key to boot into the 5.4 kernel.
Once logged in, check that you are on the 5.4 instead of 5.15. Open terminal and run

uname -r

On the 5.4 kernel, test your display link connection.


Nothing change, same situattion.



Are you using Intel Integrated Graphics with AMD Dedicated?
Or is it AMD Only?
I ask because I found this pinned post on the Display Link forums:

AMD ONLY and links direct to the main website. This is crazy... :slight_smile:

If I try to install drivers from synaptics/display link site i go with instructions:
dkms is already the newest version (2.8.1-5ubuntu2).

File has beed download it to folder Downloads and unzip as well there.
I do as they say in instruction:

To install the release, from a terminal window, with root permissions use the command:

sudo ./displaylink-driver-XXXX.run

SO i put into terminal:
sudo ./displaylink-driver-5.6.1-59.184.run
and i got:
sudo: ./displaylink-driver-5.6.1-59.184.run: command cannot found

that part i don't get, what i did incorectly so command cannot be found?

Best Regards

This is a failing on Display Link not properly naming the file or giving precise directions.
If you downloaded it; it ended up in Downloads. Then extracting it, it would be in ~/Downloads/DisplayLink USB Graphics Software for Ubuntu5.6.1-EXE
The spaces in the name creates white noise for the terminal. So rename that folder to just displaylink-driver.

You can use the change directory command to get the terminal in there:

cd ~/Downloads/displaylink-driver

Your terminal prompt should now show it in that directory.
Now run the command:

sudo ./displaylink-driver-5.6.1-59.184.run

1 Like

You are life savier :slight_smile: thank you, now i will know what no command could mean:)
Ok, so i installed, but nothing happened. Still slugish screen.
I spoke with someone from Display and they send me this fix to try:

but i don't understand what should i do.
there is a link to the whole drivers package inside, that i have already ,so how can i try this fix?
What command should i use to download those files and install?

1 Like

Pull the code:

On the upper right side, you should see a big green button marked code
Click that and a menu pops up. At the bottom of that menu, it offers you to `Downlaod Zip.
Download it - it should appear in your Downloads folder.
Extract the .zip file with right click > Extract here
Open terminal in this directory either with Right click > Open in terminal (If you have that feature enabled) or with

cd ~/Downloads/evdi-devel

Run the installation:


sudo make install

Now, I tried installing this to test if you might run into any problems. And, I came across a problem.
The makefile calls upon a dependency for (Libdrm-dev).
Once again - we confront how Display Link really just shows no real support for Linux and Open Source.
IF it gives you the same error, here is the .deb package for libdrm-dev:


On mine, that still did not work, but I also have a different system with different drivers. You might have more luck. Please report if not...

1 Like

I got during installation:
DEPMOD /lib/modules/5.15.0-52-generic
Warning: modules_install: missing 'System.map' file. Skipping depmod.

other things installed.
I tried this with synaptics drivers and than with adnanhodzic - effect the same.

No luck. Fact for the first time mouse was for like one minute not slugish on all screens, bad after that everything back to "normal" slugishness.

Thank you for putting time and effort into that.

Can you grab a LiveUSB of Ubuntu 21.04 or 22.04 and test your Display Link monitor setup on those trial versions?

i will do that and will let know how it works

I go with ubuntu 20.14, similiar behaviour..