DNS lookup failing Dell Precision

Hello all. I need some help with install of Zorin core on Dell precision laptop. All is well with the install and the Wifi adapter is recognised, and initially networking works. However after about 5 mins DNS lookups fail and I can't connect to sites on the internet. I have tried disabling IPV6, and specifying DNS servers explicitly in the network options but this does not fix the problem. I tried modifying resolv.conf by adding DNS addresses, and this does fix the problem temporarily, until resolv.conf gets overwritten. Its an Intel centrino adapter if that makes a difference. Any help appreciated.

Lets begin by disabling power management, as its possible that might be the issue.

CTRL ALT T to enter terminal.

xset -dpms

For the record, I had this problem on Windows once, and I think it was a problem with my router. But you could also try power cycling your modem and router and see if that fixes your issue too.

  StarTreker

yoda
Your Tech Support Guru

Thank you. Power management is off as is bluetooth. I have rebooted the router (Asus). I disabled power management via the GUI, should I also disable via CL?

1 Like

Lets try this in terminal...

sudo iwconfig wlan0 power off

If still not fixed, maybe try this?

sudo apt-get install linux-headers-generic build-essential git 
git clone http://github.com/lwfinger/rtlwifi_new.git
cd rtlwifi_new
make
sudo make install

Then reboot your system, hope this works. Because if you indeed said you disabled power management already, and the system is not allowed to turn off power to the WIFI adapter, then it can't be that unless its either driver related, or the adapter is failing, or something else is going on.

2 Likes

Thank you. That resolved it.

1 Like

Thats good to hear! Glad that we were able to help you solve the problem. Please be sure to mark the post that solved the issue. Thanks!

   StarTreker

yoda
Your Tech Support Guru

@holdgaj If that is true, could you please go to StarTrekkers post and mark it as :ballot_box_with_check:Solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.