Don't get internet connection

I'm new with Zorin and any Linux system. Since I use zorin I have shared the internet of my cell phone, last Night was the last time I connect in this way. Today I can't get internet at all, I don't even use my laptop since last Night. I also use zorin connect that way I don't work either
Sorry about My English, accept any idea

1 Like

Are you connecting through phone because phone is your only option?

Yes right now it is

I cannot really fathom any updates in Zorin rolling through that may cause this. This does not mean there are none, only that it is not my first suspect.

Can you please run the Updater on your Cell Phone and once it is complete, reboot the phone?
Then enter the settings and check your Phone Tether configurations per your phone make and model instructions.

I had thought Zorin Connect communicates to the computer using the existing Wifi... I was unaware it can work over phone tether or Phone Hotspot.

I tried this but not work, thanks any way. My phone share the internet fine with other divices the problem it's My laptop when I try ping a DNS it says
"ping: dns: Temporary failure in name resolution"
When try ping on a ip (e.g 8.8.8.8) ir says
"ping: sendmsg: Operation not permitted"

Let's check your wifi hardware and drivers.

sudo lshw -C network


Ok, now what?

I do not see anything wrong there...
What does

dkms status

show?

It only says Virtualbox and it's version

Ok...
What happens if you boot into the earlier 5.15.0-52 kernel?

The problem persited. Now I'm with a wired ethernet connection and still the same. I'm thinking about reinstalling

It is amazing how a Fresh Install solves many problems. If you are fine with it... I would say to go for it.

It worked perfectly, this time I'm answering from the laptop in fact :sweat_smile: Thanks for everyrhing

I moved the solution mark to your post - as that is where the proposal was made. THis makes it easier for other members to follow right to where to find the actual solution.

I am glad that worked.
If you run

sudo apt update && sudo apt dist-upgrade

and everything is still working, I would suggest just continuing on as normal.

If after the upgrade everything is not working, we may need to find out what the actual package was that broke things so you can relay on your upgrades safely from today onward.