Dual booting with windows 11

I have actually been unable to follow along on the Computers - as in what are their specs? What Make?
You mention several, but I am not sure if there is one that is known to have hardware compatibility issues.
If we can forget about the ones where everything is working fine and focus only on that which is not, it may help.

List out the hardware Details so we can check if there are any unsupported hardware components.
At 5 - 7 years old, it seems unlikely - but it is possible.

As far as Dual Booting:

Windows is its own OS and Linux OS's are their own OS. They do not cross share information - at all. None. Configurations and settings on Windows are 100% independent from any on Linux (Zorin OS, in this case). They do not and cannot interact in any way.
The only thing that can affect both is something in BIOS (Motherboard) settings.
Remember, the motherboard BIOS has its own operating system. The OS that you install, Windows or Linux, communicates with the Motherboards built in OS, it does not run it.
And these days, we do see motherboards including operating systems that have configurations for things like sound hardware - which is... odd. Most likely, it is due to the trend in Gaming machines where manufacturers are looking for some kind of Competitive edge over other brands.
These Mother board settings can inhibit or even prevent the Users Operating System from having full functionality however.

1 Like

It's the new computer that iis giving me issues, the older ones run fine on Zorin. But Zorin is not booting in in normal, only safe, which means drivers, and devices are missing or cut to boot in, I feel I'm missing those.

Again, working with Limited Information here...
You might try a later kernel on the New Computer.

sudo add-apt-repository ppa:tuxinvader/lts-mainline

sudo apt update && sudo apt install linux-generic-6.02

Reboot and test.

I even reread the full thread to try and gain a little more understanding.

If you wouldn't mind, since you haven't already and we're not in your head or looking over your shoulder, describe in detail your computer specifications and the process in which you installed Zorin.

Some immediate questions come to mind that may aid you in providing information:

  • Did you load into Zorin live on the USB?
  • Did you have any issues with graphics in Zorin Live?
  • Did you use the something else method to install Zorin?
  • Did you choose a drive or partition for Grub installation?
  • Did you overwrite the windows boot manager partition when installing grub?
  • Did you disable TPM, Fast Boot and Secure Boot?
  • Is Zorin in its own drive or sharing space on the windows drive?
  • Did you change the boot order in bios to have Zorin loaded first, if you did not overwrite the windows boot manager partition?
  • In the live image, did you take notice of the video card driver in use in the software updater application other tab?

We can guess all day and night, but with this information, along with your computer specs we can begin to narrow down where the issue resides and what needs to be done to resolve it.

Without this information we will be wasting your and our time for any possible solution.

no I loaded into the safe graphics mode and chose the first safe mode to load.
In trying out Zorin - no graphical errors - though the system does not recognize the exterior monitor and runs generic, so no sound unless I plug headphones or speakers to computer itself.
yes
as far as I know a partition
?
yes to two of those - TPM - first I've heard mention of it - explain how or least why-
Saring space with windows on a 2 tet fazang drive
Zorin shows up when going to F7 which brings up a boot menu - I pick the Ubunto choice and go from there. In the Bios itself - I do not see ubunto, to select it to be first.
No - tell me how and I will.
I appreciate the help.

so now from calling up the boot menu I can choose ubuntu - and Zorin now logs in with no issue, so first thing I'd like to do is get Zorin to recognize the video from the HDMI port so to get those properties and get sound back.
Second I would like upon start to just see a menu of the two OSs and select from there. I got it to load properly by downloading a ubuntu app for video codexes, codes, and drivers associated with the latest version.

In the bios, the boot tab allows you to change boot order. Choose the Ubuntu installation first, then Windows. This will give you the grub menu to boot into Zorin or Windows.

The video driver can not be shared with you. Since the Neauveu driver works, except for sound it will allow you to boot in at least.

We cannot share what driver to use because you still didn't share your pc specifications. If you refuse to, that is fine, but this is a far as we can aid you. Have you tried Google? There are also other threads related to 4K installations, found easily by the search of this forum.

Try Introduction to General Help - Please Review before posting

Am following those threads as well. Thank you.
Beelink desktop, pro-5 - I5 - 10 cores, threads 12 12th gen, 64m ddr4, iris graphics, - what else you need.
Also disabled TPM - figured out.

OK - I've got it to dual boot - cruised the Bios a bit - now is there a way to maybe restore any app/drivers not used due to install in safe mode?

Would you provide the output for lshw -class display.
I recognize you said iris graphics, but the drivers are model specific for most components.

This it?

lspci
00:00.0 Host bridge: Intel Corporation Device 4601 (rev 04)
00:02.0 VGA compatible controller: Intel Corporation Device 46a8 (rev 0c)
00:06.0 PCI bridge: Intel Corporation Device 464d (rev 04)
00:14.0 USB controller: Intel Corporation Device 51ed (rev 01)
00:14.2 RAM memory: Intel Corporation Device 51ef (rev 01)
00:14.3 Network controller: Intel Corporation Device 51f0 (rev 01)
00:16.0 Communication controller: Intel Corporation Device 51e0 (rev 01)
00:17.0 SATA controller: Intel Corporation Device 51d3 (rev 01)
00:1c.0 PCI bridge: Intel Corporation Device 51b8 (rev 01)
00:1c.4 PCI bridge: Intel Corporation Device 51bc (rev 01)
00:1f.0 ISA bridge: Intel Corporation Device 5182 (rev 01)
00:1f.3 Multimedia audio controller: Intel Corporation Device 51c8 (rev 01)
00:1f.4 SMBus: Intel Corporation Device 51a3 (rev 01)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Device 51a4 (rev 01)
01:00.0 Non-Volatile memory controller: Device 1e4b:1202 (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 15)

Appreciate the help - I've got no sound now - including exterior speakers and headphone - both of which I had at the beginning - now lost - wierd.

There seems to be limited Linux support as of yet. There are two ways to get a driver that will work with that card:

You can either install a new kernel with the commands:
sudo apt update && sudo apt install linux-oem-20.04
which is supposed to include the iris drivers.

You can attempt to use the i915 driver, which is what iris falls back to if it is under a gen 4 chip. You can attempt to use the i965 drive by way of Mesa, the fallback for the gen 4 chip. You won't have to choose, it should detect which version the chip is and use the proper driver from the following repository:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update
sudo apt dist-upgrade

This repository doesn't support focal (the version of Ubuntu Zorin is based).

From here, if your system uses mesa, you can type:
$ export MESA_LOADER_DRIVER_OVERRIDE=iris
to force the use of iris drivers. If it doesn't use mesa, you are stuck with the i915/65 for basic functionality.

If there are still issues, you could attempt to add grub parameters that may assist:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i915.enable_psr=0  i915.enable_fbc=0 i915.enable_guc=2

You may have to experiment with each of the i915.* parameters to see if all, some or just one is necessary. These will not work if you are using wayland.

Be sure to run sudo update-grub when you make modifications to the grub file prior to reboot.

No, that is the wrong output. You used lspci, which is not useful. I had provided the command exactly as you needed to input it above...again, here it is lshw -class display.

Slow down and read. This isn't something you can skim and get right. You are likely to break your system further if you just input commands without knowing what they do.

1 Like

Oibaf has dropped Focal support:

Supported Ubuntu versions:
- 22.04 (jammy) <- supported
- 23.04 (lunar) <- supported
- 23.10 (mantic) <- supported
1 Like

OUCH...didn't look that far into it.

Hope he has mesa then....otherwise, I'm not sure what to do other than the kernel update.

@ERZ for reference: Ubuntu 20.04 no driver loaded for Intel Iris Xe Graphics - Ask Ubuntu and Intel® Iris® Xe MAX Graphics with Linux* — Intel® software for general purpose GPU capabilities documentation

I did the ubuntu kernal update that you sugested - restarted twice - it worked on the second shot - can use headphone and exterior speakers. I can work with this, but would love for it to recognize the monitor's sound system over the hdmi - then it would be totally smooth.

Are there Bios securities that I should turn back on now that it runs and works?

The drivers are included in the kernel and should be assigned, but you are not missing anything by leaving secure boot off. It only checks driver signatures, provided by Microsoft... which is pay for signature, which doesn't mean much.

Fast boot should stay off. It only really benefits windows.

TPM is M$ only security, Linux hasn't adopted it yet.

See a pattern here?

As Iris is developed for Linux, you will find functionality added, probably including the monitor's built in speakers. Upgrade to Zorin 17 when it's released as newer kernels will get the changes first.

1 Like

Thank you!

How long before Zorin 17 comes out?