Zorin Forum

Edit right context menu

Hi again, still day 0 for me for Linux or anything not Windows related. I would like to learn how to edit the right context menu. you know when you right click on your desktop and the menu pops up. Well there a section in there I want to try to change a bit, but I would like to know how to do it. I have researched this nautilus-actions program, but I tried to install it, but I can't seem to get it running. Anyone know how to edit the context menu?

Which DE are you using? That might change the answer :slight_smile:
From a quick search, it seems nautilus-actions is no longer supported.

What is a DE?

Apologies, DE means Desktop Environment - which version of Zorin are you running?

Ah, ok I learned something :slight_smile: I am using Zorin OS 16 Pro. I do not know the underlying environment that goes with that.

Gnome.

You can change many aspects of the appearance of the menu using a custom gtk.css file. However, you may need to specify what exact changes you want to make... If you are looking for something like adding options or removing them from the menu, that will take entirely different methods.

Ah, ok for instance I have uninstalled LibraOffice and installed OnlyOffice as I like it better. But when I right click and hover over the new document it gives me the listing for LibreOffice spreadsheet document etc... I would like to either remove those or even better have them open an OnlyOffice version instead. Any suggestions?

I know what you mean... I have often been annoyed by such things.
Editing your mimeapps list may be the way to go... But first - have you set Open Office as the default application to open with?
Selecting "Open with Other Application" should give you a List of applications from which to choose- then a button for "Set as Default"

In Nautilus "Files" (Zorin Pro and Zorin Core), right click, then select Properties, then the Open with tab. In this window, you can "Set as default."

When I have Libre and Only Office both installed I did the part of Open with Other Applications and I clicked on Only Office but it did not give me any Set as Default button. Is there another way to ensure it is the default? The reason I ask because I went into the Default applications settings and it only lists Web, Mail, Calendar, Music, Video, and Photos that you can associate things with.

Are you using Core or Lite?

(See this post to add this to your profile on the forum):

I just updated that in my profile, I am using the pro version.

This should apply in your case.

Okay, that is now set as default, now is what is the way to change the right context menu to allow me to make OnlyOffice under new documents what will show up instead. Because right now when I click on the LibreOffice Calc link it makes a LibreOffice Calc spreadsheet, but when I double click to open it, nothing happens.

Nothing happens because you removed it. :wink:

Set as default, you shouldn't need to right click and open with application - just double click and it will open to the default you set: OpenOffice.

However, if you want to adjust the menu anyway... You can edit the mimeapps.list.
In Zorin OS Pro, it should be in ~/.config (ctrl+h to see the hidden files, those with a period in front)
Open mimeapps.list in your preferred text editor, then hit ctrl+f to open the search
Search for libreoffice
Here, you can replace the instances of libreoffice-EXAMPLE.desktop
with the desktop file for OpenOffice, instead.

Okay, it is working. Maybe I didn't double right click as I thought I had. Okay I can live with it now :slight_smile: Solved my issue on here. Thank you.

1 Like

Okay, I have found my way to the mimeapps.list and here is what is in there...

[Added Associations]
x-scheme-handler/sms=org.gnome.Shell.Extensions.ZorinConnect.desktop;
x-scheme-handler/tel=org.gnome.Shell.Extensions.ZorinConnect.desktop;
application/vnd.openxmlformats-officedocument.spreadsheetml.sheet=org.onlyoffice.desktopeditors.desktop;
application/vnd.oasis.opendocument.spreadsheet=org.onlyoffice.desktopeditors.desktop;

[Default Applications]
text/html=thunderbird_thunderbird.desktop
x-scheme-handler/mailto=thunderbird_thunderbird.desktop
x-scheme-handler/mid=thunderbird_thunderbird.desktop
x-scheme-handler/webcal=thunderbird_thunderbird.desktop
x-scheme-handler/webcals=thunderbird_thunderbird.desktop

I am not seeing anything about Libreoffice. Could it be I need to do a restart of my system to get it to apply?

Reboot works wonders.:wink:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.