Zorin Forum

Efi parition got deleted and now my os wont boot

if i just format everything and install the os again will it work?

Not unless you install as Legacy using MBR.
In order to install as EFI, you must have an EFI partition.
Have you tried using Gparted in LiveUSB to create an EFI partition to see if that works?

i did it didnt show an efi file type

You mean FAT32?

but what about completely new ssds do they come with efi partition built in?

oh no it did show dat

well it doesnt matter it worked

EFI partitions must be fat32. You shouldn't have to create or modify the EFI directory structure because it will be created by the OS on installation. When going this route, you only have to create the partition, as fat32 in the size you want, as well as the root partition, in whatever FS you decided upon, and you are done. /home and /swap are optional. The installer will populate the EFI and root partitions with the necessary structure and files.

I anticipate you having issues later if you leave the EFI partition as ext4.

Marked solution. 269

Hi there,
I did this too
The difference for me is that my os drive is encrypted. The efi partition was on another drive.
Is it still possible to fix in my case?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.