ELAN 04f3:0c00 failed to Enroll

Let's start with adding the nomodeset parameter:

The laptop doesn't give any display output. How could I access it to get it to run again?
When I start it up, it posts and then only the HP logo is on screen, not even the Zorin logo underneath.

Are you able to access the Grub Menu?
Try tapping esc or tab like you are playing Mortal Kombat beginning when you see the motherboard splash screen.
If using MBR Boot (Legacy) then instead, hold down the Left Shift Key.

If you can pull up Grub Menu, then select Advanced Options for Zorin and then select Zorin on -kernel- (Recovery)
This will lead to the Recovery Menu.
Let's first see if you can get to the Recovery Menu - if you need a refresher on the above suggestions at that point, please ask.

1 Like

I've managed to get the laptop to boot up by adding the nomodeset parameter, but now my wifi driver doesn't work anymore. When I installed ZorinOS, I had to put the wifi driver on it myself, because it has the RTL8852BE network controller which is prone to have driver issues on Linux.

I tried to recompile/reinstall the driver from

but it says

Some of those errors look like the Module for DKMS are not compiling correctly.
This usually means upgrading the kernel to one that has been patched (Or patching the code to use the #include function rather than declaring it implicitly).

I see you are already on 6.3

It would be odd but not impossible for the nomodeset parameter to cause this issue.
You might try upping to the higher kernel and testing - as well as reinstalling your wifi drivers:

I tried reinstalling the wifi drivers too, but that also didnt work

Are you running Zorin with Secure Boot enabled in BIOS? That for sure can cause some really weird issues; doesn't play particularly well with Nvidia drivers especially..

Nope, secure boot in bios was disabled by default when I installed Zorin OS onto this laptop.

1 Like

By default, via you? Just making sure it is disabled - it's a manually configurable parameter.

Also, on your terminal output, did you run the modprobe command after make install? I've got an 8723du on another machine, if I don't run modprobe and device name (in my case sudo modprobe -v 8723du), it doesn't activate; even after a reboot. Only after I initiate the driver to the device.

I tried to disable it and it was already disabled from the factory.
Also the make install gave an error in the output, and so did the modprobe after that. I don't have a screenshot of it tho right now, ima redo the instalation process and screenshot the output from make install and modprobe rq.

I took screenshots after every step

This is after the make

This is after the make install

This is after the sudo modprobe

This seems to have a different way to install with kernels above 6.0. If there are any drivers in there now, it may be good to remove them before trying again. This was where I found that info on kernels. It also appears that your make command didn't create the *.ko that's showing error on make install. Not sure if that's from the gcc in your 6.3 kernel - same version though.. :thinking:

You may run into the same thing I have with my RTL chip - all my kernel updates require me to reinstall the driver; because they're not included. I just run make clean and go from there.

Were you on the stock 5.x.x kernel when WiFi was working?

When I freshly installed ZorinOS with the stock 5.15.0-84 kernel the wifi driver wasn't installed. I installed the wifi driver from that link I showed earlier and then it worked fine until I installed the 6.3.13 kernel in order to make the fingerprint sensor work. Since I have this 6.x.x kernel the wifi driver doesn't work. I even tried reinstalling the driver from scratch by cd-ing into the directory with the driver and sudo rm -f -r-ing the directory of the driver since it is from git. Then I redid the entire long instalation procedure and still nothing.

Can you please link to the driver you are using?
May need to find a different driver source...

1 Like

I got the driver from here

1 Like

Kelebek or HRex39?

Works with the driver in the second hyperlink "this" I posted

Is expected, the driver isn't included - but fortunately there's a way!

And the driver you just posted the link to where you downloaded - won't work with the 6.x.x kernels.



Try the rtw89 one: GitHub - HRex39/rtl8852be: Realtek Linux WLAN Driver for RTL8852BE - That's the one HRex39 lists to be working in kernels greater than 6.x.x - just be aware, it's no longer maintained.

1 Like