Errno 5 on installation specific to Zorin OS

Hey, so it's been 5 months since my first GNU/Linux install, and i am loving the experience. Recently, on Zorin OS, i had to reinstall the system because i was messing around with files but messed with the wrong one. I did it other 3 times before, but this specific time i got that "Errno 5: Input/Output error". What i have tried:

  • Waiting for the filesystem check (on the startup), no errors
  • Creating a new partition then installing the system to it, not successful
  • Secure Boot and Fast Boot both disabled
  • Installing an older version of Zorin OS, nope
  • Using fsck to completely wipe out all of my SSD to complete zero, still got the same error
  • Installing another OS (Mint). Installed with no problems

From probably one month now, i have been using Linux Mint, but i really miss Zorin, and i am now downloading an ISO to get back to it. The only thing i have not tried is installing using another USB, but i'm not sure if i'm just wasting my time by trying again

If none of the solutions above worked, do i still have a chance of installing by using another USB? I really don't want it not to work, because i have already been stressed out too much about this error :frowning:

EDIT: Just tried a reinstall and the exact same error is ocurring. I don't know what to do

Were you able to run Zorin OS in live mode, before trying to install it?

Looking at past posts re error 5, point to either bad download, bad USB stick, or USB burner software. I suggest you re-download the .iso, check the SHA256 checksum is valid, re-format the USB stick or use another, and use a different USB creation tool.

Also see: Before you install

1 Like

I would suggest to download the ISO again and check the Checksum. You could try a different Mirror Server, too.

To try another USB stick I would recommend, too.

The Question is what Program do You use for creating a bootable USB Stick? When You are on Windows I can recommend Rufus. There You can directly choose between GPT (for newer BIOS) and MBR (for older BIOS). Format the Stick in the FAT32 Format.

Oh, and try a different USB Plug on Your PC.


I have used Etcher. People say it's good for installing Linux

1 Like

Also here's a screenshot of the last ouputs before the error, idk if it's necessary though

As for looking at the checksum: just waiting for a filesystem check, as mentioned here, should do the work. One thing i should mention is that, my internet was wild slow when installing the ISO file. It has been like this for months now, and i don't know if a bad internet connection can actually affect that much of the ISO. Last thing: i have tried installing the system again several times, all of them in different periods, and they all gave me the same error, so this isn't a mirror problem, isn't (probably) a USB problem and isn't a my computer problem

1 Like

Just one last mention: after the error, when trying to install again it shows this message

1 Like

I have used Etcher without Problems, too. But here in the Forum were other Users who had Problems with it. So, Rufus could be an Alternative to try. But - to say that clear - Rufus only works on windows. So, if you want to try it, you need a Windows PC.

I can't understand what there is written but it seems that there is a Problem with a CD/DVD Drive? Do You have one in Your Machine? If Yes, is it possible that You can plug it off for Installation?

It would be interesting to know what stand in /var/log/syslog for this Problem. I have found a Solution on askubunto. Maybe that could help:

1 Like

In theory, this shouldn't matter; browsers can resume a download where they left off. What matters is that the signature or checksum of the downloaded ISO file matches exactly the one listed in the website.

Try using another USB, and another physical port for it. Otherwise, I'm tempted to suggest following this instructions, but I'm not sure if this is the issue. Also, check the file at /var/log/syslog to see if there are any errors (this should be when the error appears). You can use the built-in text editor (don't use LibreOffice) or through the terminal:

sudo less /var/log/syslog

and press G to scroll all the way down where the most recent logs will appear.

1 Like

I'll try to get the last logs posted here. At the moment, i am trying a download from a different server (the Ireland one). The download from this server is much faster for me so it is easier to check if that one works. About the USBs, i don't have much options now because all of my working USBs/MicroSDs have been used to try and install Zorin, and the last two ones are being used to backup my files in case of data loss

But i am really really curious about why this is happening specifically to Zorin OS, because i can install Mint just fine when using the exact same USB i'm now using to try to install Zorin

Got a look onto the logs, and found some interesting lines

1. May  1 01:36:40 zorin snapd[24899]: daemon.go:340: adjusting. startup timeout by 30s (pessimistic estimate of 30s plus 5s per snap)
2. May  1 01:36:40 zorin snapd[24899]: backends.go:58: AppArmor status: apparmor is enabled and all features are available
3. May  1 01:36:40 zorin snapd[24899]: profile.go:326: snapd enabled root filesystem on overlay support, additional upperdir permissions granted
4. May  1 01:36:40 zorin ubiquity: umount: /target: o alvo está ocupado.
5. May  1 01:36:40 zorin ubiquity[21946]: debconffilter_done: ubi-partman (current: ubi-partman)
6. May  1 01:36:40 zorin ubiquity[21946]: dbfilter_handle_status: ('ubi-partman', 10)

Line 4: "umount: /target: the target is occupied"

Strange line that appears before the ubi partman crash, idk if that's a problem or just a warning

I don't have CD/DVD drives. This is probably talking about the installation drive, which for me is an USB

When following the instructions on askubuntu, i can't get pass the "right click -> new", it does not let me make changes to my main drive

Although i still can easily create and delete files from the main drive on nautilus. One thing to mention is that, when i get that errno 5, i get sent to testing mode, and trying to install again makes this message appear. When checking around it, i've found that when directly going into testing mode without trying to install anything makes the hard drive appear normally on nautilus, as if it was an connected USB, but when the opposite (trying a install then testing), instead of my main drive appearing normally in nautilus, it now appears in /target

/home folder inside /target:

That probably is the reason why the partman crash only appears after an first attempt to install (when errno 5 happens)

I see on Your GParted Picture an interesting Detail: On /dev/sda2 is a little Key. Is this Drive encrypted?

1 Like

I think not. This print was taken after trying a install, so it probably has that key because the drive is now "being mounted" on /target. I'll turn on my notebook later and try this without trying an install first

1 Like

Strange. I did what i said above, and now there is no key appearing. Still, i don't have access to the "new" button. When checking for the partitions created, i noted that it is already configured as said on askubuntu:

  • A partition with with filesystem as fat32
  • fat32 partition with a size of 200MB (on mine it is 512MB but i don't think that makes a difference
  • fat32 partition marked with "boot" flag (it has an "esp" flag too, i'll try to remove that flag and try to install again)
  • Installation target partition with filesystem as ext4

i did a check to see if that can be the USB i'm using at the moment, but there's not bad blocks in it
Captura de tela de 2024-05-01 14-53-39

1 Like

Also checked the sha256sum of my downloaded ISO from Ireland and they match
Captura de tela de 2024-05-01 15-44-26
I am now checking the integrity of the USB i am going to use to install it by using "sudo badblocks -v /dev/sdc". If both sha256sum and the USB are fine, do i need to change the software used to create the bootable USB (BalenaEtcher)?

1 Like

I think i know what the problem is, think

So i've been trying to backup that downloaded ISO to another USB so i don't need to re-download it. After doing that, i started to download Etcher when suddenly the download fails. Checking the USB used to run the test: BOOM! 0 bytes out of 4GB...

... trying to create a new file... BOOM! Input/output error...

So i think i have a conclusion about this: out of all the USB's i have here, the ones working or without bad blocks have at maximum 4GB, so probably at the installation all of these 4GB are filled and no space is left for more copying of the files. I'll try to fix the badblocks of one of the USB's that has enough space here and try a installation on it.

Edit: nope, not the problem

1 Like

Yes, you could try a different Tool to create a bootable Stick if You want try that. I called in a Comment Rufus but that only works on Windows. If You don't have the Possibility to use Windows Etcher is okay. As a USB Stick a 8GB Stick would be good if you have one.

So, to take a Step back: You want to (re-)install Zorin on your Machine. Only Zorin, no Dual-Boot.

What Option do You choose in the Installer to install the System? The ''Erase the Disc'' Option or the ''Something else'' Option? When You choose the first One You don't have to do anything.

When You choose the 2nd Option You need two Things:

  1. a FAT32 Partition (250mb or more)
  2. a ext4 Partition

Both You already have. On the FAT32 Partition You set the Mounting Point /boot/efi and on the ext4 Partition You set /, only a / nothing else.

1 Like

What i am choosing:

  • Something else
  • Choosing "journalling with ext4"
  • Unselecting "format this partition"
  • Mount point at "/" on the drive i want to install

The fat32 partition with 250MB or more is already created, while the target drive is on ext4:

Also, i've tried installing with an 16GB microSD but, still the same problem. Errno 5, then ubi partman 10 when trying again. I will set the try setting the mounting point of the fat32 partition as /boot/efi and give you an update if it worked or not

Oop! Found a problem: It is showing as EFI instead of FAT32 on the installation, and when i change It to FAT32 it gives me a warning that the system may not boot or the installation may occur incorrectly. Should i continue anyway?

The message in question:

OBS: When EFI is selected i cannot set the mount point