Error "bpfilter: read fail 0" When Using a VPN

Hi folks,

I seem to have this odd problem with Zorin OS 16.2 specifically. I have tried a few VPN clients and the behaviour is the same. Here's an example:

PIA VPN client - when running this, the app is extremely slow to connect/disconnect. If I reboot the system, I get spammed with a load of bpfilter: read fail 0 and it would take sometimes several minutes for the system to reboot.
Windscribe VPN - The app seems to work ok and is responsive enough however, once again when I reboot, I am spammed with bpfilter: read fail 0 messages and it will take several minutes to reboot.

I should add that this only happens with Zorin OS. I have used countless other distros and I don't have this problem. It has also happened on 2 different Ryzen laptops and the WiFi card doesn't seem to matter as I've tried Realtek and Intel cards. I'm really not sure how to troubleshoot this and would appreciate any pointers. Thank you!

Zorin OS 16.2
Latest 6.3.1 kernel

Just a guess, but it might be either the kernel or Ubuntu 20.04 (what Zorin 16 is based on).

I should also add that updating the kernel comes with risks.

Sorry I should point out that this also happens on the default kernel 5.15.0. You may have a point there about the Ubuntu version. It didn't occur to me that Zorin is using an older Ubuntu version. It doesn't happen on other Ubuntu distros I've tried, but maybe it's because they are based on 22.04 or later. Apparently they are harmless and there's a way to mask them, which I am still trying to work out. That would do as a fix until (hopefully) the next Zorin release. Thanks :slight_smile:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.