Error detection of usb pendrive in virtualbox

Firstly I installed an upgrade version of virualbox 7. And create vm for win11. I have installed extension pack, virtualbox guest edition, enable usb controller 3 and add filter for usb pendrive. all done. first time it was detected without errors. but now it shows this message:


Failed to create a proxy device for the USB device. (Error: VERR_READ_ERROR).

|Result Code:|NS_ERROR_FAILURE (0x80004005)|
| --- | --- |
|Interface:|IConsole {872da645-4a9b-1727-bee2-5585105b9eed}|

I have also tried downgrade to virtualbox 6.1 but no solution yet.

hasibul@hasibul-S551LN:~$ lsusb
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 007: ID 0bda:0139 Realtek Semiconductor Corp. RTS5139 Card Reader Controller
Bus 002 Device 006: ID 04f2:b40a Chicony Electronics Co., Ltd USB2.0 HD UVC WebCam
Bus 002 Device 005: ID 0489:e069 Foxconn / Hon Hai BT
Bus 002 Device 025: ID 1f75:0917 **Innostor Technology Corporation PenDrive**
Bus 002 Device 012: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 002 Device 009: ID 1c4f:0026 SiGma Micro Keyboard
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

USB 3.0 has never worked well for me in Virtual Box. Virt-Manager is much better for USB 3.0 you just need to add the hardware in machine details of the VM you are working with. .vhd files created in Virtual Box can be imported into Virt-Manager. (Virtual Machine Manager - can be installed with Synaptic Package Manager.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.