Error downloading Zorin OS 16

Clicked download on the zorin website, got this:Screenshot 2021-10-19 12.17.28 PM
Is there something wrong with the servers?

Hi and welcome to the forum :slight_smile:

I tested myself.

There is absolutely no problem on my end.

I see R2 got released as well :). What does R2 fix ?

Oh, was it?
I did not notice it.
Perhaps a newer kernel?

I tried Connectivity Diagnostics and the only problem was that the gateway could be pinged.

idk if this has anything to do with the problem

Can you ping to zorin site?

Just figured other websites don't work they show the same error message probably something with my interent. I'll try connecting to a different network

Maybe a untrusted installer :joy:


ping gives me

64 bytes from ( icmp_seq=1 ttl=50 time=30.4 ms

also did ping Chrome Web Store which is another website that stopped working and got this:

ping: Name or service not known

The website works fine, but the download link shows the error

Just checked in Virtualbox, says, so its not a newer kernel. I like to know what this version is about. According to Aravisian the first (R1) was about some app that was installed.

So, perhaps again he can tell us what this one is about, unless he's unaware??

we need you.


same thingScreenshot 2021-10-19 1.41.06 PM

I think something is wrong on your end.
Do you have other browser to test?

I just had to restart my system because me Wifi wasn't showing. After that - see for yourself, I'm online now. Perhaps you could try to restart?

I was using chrome i'll try firefox

Maybe reset your router ?

I restarted my router already.
And the wifi is on i can visit other websites but not some.

It sounds like some sort of network filtering is in effect.
I wonder if @337harvey or @StarTreker has some idea.

I meant, restarting your pc and letting the drivers fire
up again.