Error found when loading profile?

I was trying to make kde apps to be more better in xfce de, so I tryed kavantum manger, and then i tryed qt5 app, i get that message after login

I have executed that command echo "remove QT_STYLE_OVERRIDE=qt5ct" >> ~/.profile as the qt5 app asked me to do
I tried to solve that by excute that comand echo "export QT_STYLE_OVERRIDE=kvantum" >> ~/.profile ,that make kvantum effect kde apps but i still get that error message in login

kvantum is very closed, allowing only that it uses its own inbuilt themes.

I recommend using qt5ct, instead.

This will allow QT apps to use any system theme you use.

I highly recommend installing preload

sudo apt install preload

to allow much faster launching of QT apps.

Below is the Default .profile contents

if [ -n "$BASH_VERSION" ]; then
    # include .bashrc if it exists
    if [ -f "$HOME/.bashrc" ]; then
	. "$HOME/.bashrc"

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/bin" ] ; then

# set PATH so it includes user's private bin if it exists
if [ -d "$HOME/.local/bin" ] ; then
1 Like

things about qt5ct is very good, i can now get kde apps theme as the same theme of other apps.

sorry , How i can use that to solve the error in loading profile?

Replace the contents of your home profile with the above; or simply use it as a template to ensure that your profile looks the same.

1 Like

sorry, where i can find the profile file, Is that /etc/profile.d?

In your Home Directory. If you do not see the files with a (.) period in front, tap ctrl+h to reveal them.
Or, in Thunar, click View on the menubar, then check "Show Hidden Files".

1 Like

thank u very much, the error message is solved now, and kde apps now is gotten the same theme of other apps. but can qt5 app do more than that? I mean can solve the problem of window sizing of some kde apps, I mean look the app itself in the above picture in my post, I can't resize it.

You should be able to resize normally... I can resize any QT app on my machine using qt5ct by the window edges.
Perhaps log out and back in and test?

ok u r right, I didn't face that problem with all kde app, just qt5ct itself and Kdenlive, I have found solution for kdenlive with it's setting which it doesn't response to qt5, but I can't reszie qt5ct itself

You mean the qt5ct settings popup window? Odd... I can resize mine without issue...
Have you rebooted lately?

may be because of that message, application not configured correctly ?

Open your ~.profile file as covered above and remove any Environment Variables. You can use what I pasted to fix your profile file.

Once done, please follow the steps I outlined in the post Tutorial I linked to.

sudo -i


Navigate to /etc/profile.d/ and open and ensure it is set to qt5ct and not to gtk2
Then open qt-qpa-platform theme - set to qt5ct not to gtk2.

Now, navigate to (I Think, please let me know if this is the wrong location) /etc/X11/Xsession.d
Open the file 56zorin-os-lite-session
It should say export QT_QPA_PLATFORMTHEME=qt5ct and not gtk3 or gtk2

That should fix the error. You may need to log out and back in when finished.

1 Like

thank u very much I go to the 3 files and make it set to qt5ct ,that solved the error message in application.
for the problem of size of qt5ct , i tried to change scaling from display in setting of zorin, I changed scaling to 1.3 I get qt5ct app in the size of other window apps and when I changed the scaling again to deafult 1.0, qt5ct app became also in size of other window apps

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.