Error opening GOG game

Hey guys, I am getting this error when trying to open a GOG game on Z16 that worked fine on Z15:

error while loading shared libraries: cannot open shared object file: No such file or directory

Has anyone had a such a problem/fixed it?

Did some digging around and I think this may be an issue with Ubuntu 20.04 having a different version of that library, but I am not sure what I can do to fix this.

Which game did you try to play?

StoneShard. Ran flawlessly on Z15...

How do you open the app? is it by installing an app or just running an appimage

This should be the package you need:

Save the file to your Downloads folder and double click it to install it.
Please update thread with the result.

The GOG installer creates a .desktop file that I open from the App Launcher.
But I can see the error message when trying to open the game from the script from the Game installation folder.

Thank you, I will try it when I get home.
Would installing it conflict with any existing (possibly newer) version of the package?

I actually get a similar issue with the game "Karlson"

derek@derek-HP-Laptop-15-bs1xx:~/Desktop/Games/Karlson$ ./Karlson_linux.x86_64 
Set current directory to /home/derek/Desktop/Games/Karlson
Found path: /home/derek/Desktop/Games/Karlson/Karlson_linux.x86_64
no boot config - using default values
(Filename: ./PlatformDependent/LinuxStandalone/main.cpp Line: 479)


I certainly hope not, since I tested it first by installing it on my regular use Zorin 16. :smiley:

My PC has not had indigestion, so far.

For this, the package needs to be rebuilt.

1 Like

Sorry for the delay in answering, I wasn't very comfortable with installing that file and, potentially, getting some error later down the line, so I was looking for another alternative.

I found this one, which has the user create a folder in the game files, paste some of the contents of the .deb you linked there and edit the script to call on that folder.

It seems, one can get away with either installing the .deb file or this approach. I have tested it, and it worked for me.

It seems to only be possible to mark one reply as a solution in this forum, so I have marked Aravisian's reply as "the" Solution because the above approach is more hacky.