Ethernet works on live usb but not on installed os

before I moved, the Ethernet was working on the 3.0 usb port getting 360 Mbps speeds.
After I moved, and everything is the same. the 3.0 usb port doesn't work for my Ethernet anymore. However, works with my snadisk 64 Gb stick with the iso on it.
I have two other ports and the Ethernet does work on them but I only get 70 Mbps. Not 360...Even wifi is only reaching 70 Mbps...I'm right near the router.
Another note, mouse works also on the usb 3.0 but not my external "larger" hard-drive. But works with the other ports. Strangley, the disk does run, just doesn't show up at all even in the Disk app.

Also, when I run the Live OS, the 3.0 usb port does work for my Ethernet..

Was thinking possibly power issue but, if that was the case, it wouldn't work even in live OS


Any ideas?
Yes everything is updated, I even reinstalled Zorin. I have the pro version. (which i realized I could ask the higher up people). If no help, I'll ask them, just have to find my membership code.


See if anything here helps (or hinders):

Thanks! been trying to figure this out for quite some time.

Internet works now. and getting the speeds I should get..

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.